Database Manager GUI

Release 730

SAP®
### Icons in Body Text

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>❗️</td>
<td>Caution</td>
</tr>
<tr>
<td>🔍</td>
<td>Example</td>
</tr>
<tr>
<td>慣れ</td>
<td>Note</td>
</tr>
<tr>
<td>💡</td>
<td>Recommendation</td>
</tr>
<tr>
<td>💡</td>
<td>Syntax</td>
</tr>
</tbody>
</table>

Additional icons are used in SAP Library documentation to help you identify different types of information at a glance. For more information, see Help on Help → General Information Classes and Information Classes for Business Information Warehouse on the first page of any version of SAP Library.

### Typographic Conventions

<table>
<thead>
<tr>
<th>Type Style</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Example text</em></td>
<td>Words or characters quoted from the screen. These include field names, screen titles, pushbuttons labels, menu names, menu paths, and menu options. Cross-references to other documentation.</td>
</tr>
<tr>
<td><strong>Example text</strong></td>
<td>Emphasized words or phrases in body text, graphic titles, and table titles.</td>
</tr>
<tr>
<td>EXAMPLE TEXT</td>
<td>Technical names of system objects. These include report names, program names, transaction codes, table names, and key concepts of a programming language when they are surrounded by body text, for example, SELECT and INCLUDE.</td>
</tr>
<tr>
<td>Example text</td>
<td>Output on the screen. This includes file and directory names and their paths, messages, names of variables and parameters, source text, and names of installation, upgrade and database tools.</td>
</tr>
<tr>
<td><em>Example text</em></td>
<td>Exact user entry. These are words or characters that you enter in the system exactly as they appear in the documentation.</td>
</tr>
<tr>
<td><code>&lt;Example text&gt;</code></td>
<td>Variable user entry. Angle brackets indicate that you replace these words and characters with appropriate entries to make entries in the system.</td>
</tr>
<tr>
<td>EXAMPLE TEXT</td>
<td>Keys on the keyboard, for example, <strong>F2</strong> or <strong>ENTER</strong>.</td>
</tr>
</tbody>
</table>
Database Manager GUI

Calling the Database Manager GUI

Screen Areas of the Database Manager GUI

Creating a Database Instance

Creating a Database Instance: Desktop PC/Laptop

Creating a Database Instance: Custom

Creating a Database Instance: My Templates

Initializing an Existing Database Instance

Database Instance Management

Managing the List of Database Instances

Connection to the DBM Server

Starting (Restarting) the Database Instance

Stopping the Database Instance (Shutdown)

Monitoring the Operational State

Closing a Database Session Manually

Creating, Displaying and Deleting Volumes

Changing Volume Properties

Displaying and Changing Database Parameters

Changing Database Parameters for Volumes

Switching on/off Automatic Extension of the Data Area

Changing Log Settings

Setting Up a Master Instance (Hot Standby)

Adding a Standby Instance (Hot Standby)

Activating, Deactivating, or Deleting Indexes

Creating, Displaying, Changing and Deleting MapChar Sets

Updating the Statistics Information

Loading Demo Data

Deleting a Database Instance

Managing the Database System Administrator

Changing the DBM Operator Properties of the Database System Administrator

Changing the Password of the Database System Administrator

Changing the Server Authorizations of the Database System Administrator

Changing the SQL User Properties of the Database System Administrator

Managing Database Manager Operators

Creating, Changing, or Deleting a Database Manager Operator

Changing the DBM Operator Properties

Changing the Password of a Database Manager Operator

Changing the Server Authorizations

Managing Database Users
Creating/Changing/Deleting a Database User ................................................................. 37
Changing the SQL User Properties of a Database User .................................................. 39
Changing the Password of a Database User ................................................................... 40
Creating/Changing/Deleting a Synchronization User ....................................................... 40
Backup ................................................................................................................................. 41
Backup Wizard ...................................................................................................................... 42
Managing the Backup Templates ...................................................................................... 42
Backup Template for a Single Data Carrier ...................................................................... 42
Backup Template for a Group of Parallel Data Carriers .................................................. 44
Changing Backup Templates ............................................................................................ 45
Deleting Backup Templates ............................................................................................... 46
Backup Procedures .............................................................................................................. 46
Back up to a Single Data Carrier ....................................................................................... 47
Back up to a Group of Parallel Data Carriers ..................................................................... 47
Backups with Automatic Tape Loaders ............................................................................. 48
Backups to Manually Changed Data Carriers (Succeeding Data Carriers) ....................... 49
Backups Using Third-Party Backup Tools ........................................................................ 50
Activating and Deactivating Automatic Log Backup ......................................................... 51
Restoring ............................................................................................................................. 52
Recovery Wizard ................................................................................................................ 53
Restoring the Last Backup in the Backup History .............................................................. 54
Restoring a Backup from the Backup History .................................................................... 55
Restoring Without a Backup History ................................................................................ 56
Continuing an Interrupted Restore .................................................................................. 56
Restoring with Automatic Tape Loaders .......................................................................... 57
Restoring Using Third-Party Backup Tools ....................................................................... 57
Restoring After Initializing a Database Instance .............................................................. 58
Restoring the indexes after a database restore .................................................................... 59
Restoring a Mirrored Log Volume ..................................................................................... 60
Freezing the Data Area (Snapshots) .................................................................................. 60
Creating a Snapshot .......................................................................................................... 61
Reverting to the Snapshot ................................................................................................. 61
Deleting the Snapshot ....................................................................................................... 62
Displaying Information ...................................................................................................... 62
Displaying the Backup History .......................................................................................... 63
Displaying Cache Information ............................................................................................. 64
Displaying Data Area Information ...................................................................................... 64
Displaying Database Activities ........................................................................................... 65
Displaying Database Parameters ....................................................................................... 67
Displaying Database Sessions ............................................................................................ 67
Displaying Log Area Information ................................................................. 68
Displaying System Tables ........................................................................... 69
Options for Diagnosing Problems ............................................................... 69
Checking Backups ...................................................................................... 70
Displaying and Deleting Database Analyzer Information ....................... 71
Checking Database Servers ................................................................ ........ 71
Reading Log Files .................................................................................... 72
Checking Database Structures ................................................................. 72
Using the Database Trace .......................................................................... 73
Displaying OMS Caches ........................................................................... 74
Displaying OMS Class Containers ............................................................ 74
Activating the OMS Monitor ..................................................................... 75
Updating the Database Software ............................................................... 75
  Updating the System Tables ................................................................. 76
Using the SQL Studio ............................................................................... 76
Using the Database Manager CLI ............................................................ 77
Database Manager GUI

Purpose

⚠️
We recommend that you use the database tool Database Studio [Extern] instead of Database Manager GUI. Database Studio has the same functions as Database Manager GUI and can be used on all platforms supported by MaxDB.

The Database Manager GUI database tool is used to manage database instances. You can use it among other things to create, monitor, back up, and restore database instances.

The Database Manager GUI has a graphical user interface and can be used only on Microsoft Windows. However, you can use the Database Manager GUI also to manage database instances that are running on a remote computer with a different operating system.

Features

The Database Manager GUI features the following functions and display options, among others:

- Calling the Database Manager GUI [Seite 8]
- Screen Areas of the Database Manager GUI [Seite 8]
- Creating a Database Instance [Seite 9]
- Initializing an Existing Database Instance [Seite 13]
- Managing Database Instances [Seite 14]
- Deleting a Database Instance [Seite 30]
- Managing the Database System Administrator [Seite 30]
- Managing Database Manager Operators [Seite 33]
- Managing Database Users [Seite 37]
- Backup [Seite 41]
- Restore [Seite 52]
- Freezing the Data Area (Snapshots) [Seite 60]
- Displaying Information [Seite 62]
- Diagnosis Options [Seite 69]
- Updating the Database Software [Seite 75]
- Using SQL Studio [Seite 76]
- Using the Database Manager CLI [Seite 77]

![The database tool Database Manager CLI [Extern] is a command line tool offering similar functions to the Database Manager GUI.]

Database Manager GUI 730 7
Calling the Database Manager GUI

To call the Database Manager GUI program, use the Microsoft Windows start menu or the relevant shortcut.

In exceptional cases, you can also call the Database Manager GUI from the command line. To do so, go to the directory containing the program `dbmgui<n>.exe` (n is a program version counter) and enter the following command:

```
dbmgui<n> [<options>]
```

<table>
<thead>
<tr>
<th>&lt;option&gt;</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-?</td>
<td>Display all command line options</td>
</tr>
<tr>
<td>-d &lt;database_name&gt;</td>
<td>Database name</td>
</tr>
<tr>
<td>-e</td>
<td>Use encrypted connection (for SAP customers only)</td>
</tr>
<tr>
<td>-f &lt;file_name&gt;</td>
<td>Open configuration file</td>
</tr>
<tr>
<td>-n &lt;database_computer&gt;</td>
<td>Name of the database computer</td>
</tr>
<tr>
<td>-nologo</td>
<td>Start Database Manager GUI without displaying the splash screen</td>
</tr>
<tr>
<td>-prompt</td>
<td>Open dialog for establishing a connection to the database instance</td>
</tr>
<tr>
<td>-u &lt;dbm_operator&gt;,[&lt;dbm_operator_password&gt;]</td>
<td>Establish connection to database instance (specify name and password of Database Manager user)</td>
</tr>
<tr>
<td>-version</td>
<td>Display Database Manager GUI version</td>
</tr>
</tbody>
</table>

Screen Areas of the Database Manager GUI

The screen of the Database Manager GUI is structured into eight different areas. You can change the size of each of these screen areas.

```
1  2
3  4
5  6
7  8
```

Contents of the Screen Areas
Creating a Database Instance

You can create a database instance on a local or remote computer using the Database Manager GUI.

Prerequisites

- **Database instance on a local computer**
  As an operating system user, you have administrator rights for the computer.

- **Database instance on a remote computer**
  Microsoft Windows: You need an operating system user for the remote computer that has administrator rights and the right `log on as batch job` or a comparable right.
  UNIX: You need an operating system user for the remote computer that is a member of the `sdba` group.
  For information about administrating operating system users, see your operating system documentation.
Procedure

Choose Instance → Create... .

Choose Next to start each of the required steps. Choose one of the following options:

- Desktop PC / Laptop [Seite 10]
- Custom [Seite 11]
- My Templates [Seite 13]

Creating a Database Instance: Desktop PC/Laptop

You can create a database instance with the Database Manager GUI using Desktop PC /Laptop. This database instance is preconfigured for use by database users and is ideal for carrying out tests of smaller applications and reproducing examples from the tutorials using demo data.

Prerequisites

Note the usual prerequisites when Creating a Database Instance [Seite 9].

Procedure

Choose Instance → Create... .

Choose Next to start each of the required steps. Choose Desktop PC / Laptop.

1. Make the following entries:
   - Database Name: Name of the database instance. In the demo environment, DEMOBD is used for the name of the database instance.
   - Database Size (MB): Size of database instance
   - Select Load Tutorial Data if you want to load the complete demo data. If you do not select Load Tutorial, the demo data is not loaded when the database instance is created. You can load the demo data at a later point in time however.
   - Database System Administrator: Enter the name and password for the Database System Administrator (SYSDBA user). Do not use special characters and do not choose the name SYSDBA. We recommend that you use upper-case letters. In the demo environment, DBADMIN and SECRET are used as the name and password respectively for the database system administrator.

2. Confirm the location of the volumes for the data and the log area or change this.

3. If you want to save your configuration as a template for creating database instances, choose Save Template as... .

4. Choose Start. If errors occur, the procedure is terminated immediately. However, the state reached before the error occurred is preserved.

5. Select Close to close the wizard.

Result

The database instance is created and transferred to the ONLINE operational state.
Creating a Database Instance: Custom

Using Custom, you can create a database instance on a local or remote computer using the Database Manager GUI. You can change all presets for database parameters, volumes and so on for this database instance individually.

Prerequisites

Note the usual prerequisites when Creating a Database Instance [Seite 9].

Procedure

Choose Instance → Create... .

Choose Next to start each of the required steps. Choose Custom.

6. To create a database instance on your local computer, enter the following:
   ○ Database Server: <local>: Do not change this entry.
   ○ Database Name: Name of the database instance. In the demo environment, DEMODB is used for the name of the database instance.

To create a database instance on a remote computer, enter the following in addition:

   ○ Database Server: Name of the remote computer
   ○ Port: Port used to address the X Server; if you do not specify a port, the default port is used.
   ○ Login Name: Operating system user for the remote computer
   ○ Password: Password for the operating system user on the remote computer

7. A computer can have multiple installati ons of the database software. Select the appropriate installation.

8. If you are using a Microsoft Windows operating system, you can specify further options:
   ○ Set the startup type for the database service to automatic: The database instance is started automatically when computer starts.
   ○ Use the login information as account for the database service: For remote computers only. The service for the database instance runs on remote computers under the name of the operating system user logged on and not under SYSTEM.
   ○ Automatic extension of data areas: The data area is extended automatically where there is insufficient memory space.
   ○ Automatic update of statistics: Statistics for the SQL Optimizer are updated automatically.

9. Specify the Database Manager operator (DBM operator). In the demo environment, DBM is used both as the name and password for the Database Manager operator.

Select Use Encryption if you want to encrypt communications between the client and the X Server.

   The database system converts the name and password of the DBM operator to upper-case letters.

10. Decide how you want to assign initial values to the database parameters.
○ **Initialize parameters with default values**
  Here, the database parameters are assigned the default values of the database software.

○ **Copy parameters from existing database**
  In this case, the initial values of the database parameters are taken from an existing database instance. Choose the database instance from which you want to copy the parameter values.

○ **Restore parameters from a backup medium**
  In this case, the initial values of the database parameters are taken from a complete data backup. Select the complete data backup you want.

11. Choose a database instance type.

12. Adjust the database parameters (*General/Extended*) as required. To change a database parameter, select the database parameter and choose **New Value**. Enter the new value for the database parameter and confirm this. The database parameters are checked when you exit the input screen. You may be asked to make and confirm changes before you are permitted to exit the input screen.

13. Define your data volumes and log volumes.
You can copy the proposed values or change them as required.
To define new volumes, choose **New Volume** and enter the size as well as the name or absolute path of the volume.

14. Choose from the following options:

  ○ **Create and start instance**
  Specify the database system administrator (SYSDBA user). Do not use special characters and do not choose the name SYSDBA. We recommend that you use upper-case letters. In the demo environment, DBADMIN and SECRET are used as the name and password respectively for the database system administrator.

  ○ **Create instance for recovery**
  The database instance is created and transferred to the ADMIN operational state. You can use this database instance for a recovery only. The details for the database system administrator (SYSDBA user) are transferred from the data backup.

1. You can also make further settings:

  ○ **Select Load Tutorial** if you want to load the complete demo data.
  If you do not select Load Tutorial, the demo data is not loaded when the database instance is created. You can load the demo data at a later point in time however.

  ○ **Select Activate overwrite mode for the log area** if you wish to activate overwrite mode for the log areas.
  If you do not select Activate overwrite mode for the log area, overwrite mode is deactivated, that is, a full log area cannot be overwritten until after the log entries have been backed up. You should therefore activate automatic log backup. You can activate overwrite mode later on.

  ○ **Select Automatic log backup** if you wish to activate automatic log backup.
  If you do not select Automatic log backup, automatic log backup is not activated after a database instance has been created. You can activate this at a later point in time however.

2. If you want to save your configuration as a template for creating database instances, choose **Save Template as...**
3. Choose Start. If errors occur, the procedure is terminated immediately. However, the state reached before the error occurred is preserved.

4. Select Close to close the wizard.

**Result**

The database instance is created in accordance with your entries and transferred to the ONLINE operational state.

In addition to the necessary users, volumes and so on, an initial backup template called INITIALBACKUP is created and data is backed up to this template. To create additional backup templates, proceed as described in Managing the Backup Templates [Seite 42]. To carry out additional backups, proceed as described in Backup Procedures [Seite 46].

---

### Creating a Database Instance: My Templates

*My Templates* enables you to create a database instance with the Database Manager GUI using existing data from a template for database instances. You can change all presettings for database parameters, volumes and so on for this database instance individually.

**Prerequisites**

Note the usual prerequisites when Creating a Database Instance [Seite 9].

You must have created templates for creating a database instance.

**Procedure**

Choose Instance → Create... .

Choose Next to start each of the required steps. Choose *My Templates*.

1. Choose the required template for creating a database instance using Open Template.

2. You can change the template for creating a database instance under Properties.

In order to create a database instance, proceed as described in Adding a Database Instance: Custom [Seite 11].

**Result**

The database instance is created in accordance with your entries and transferred to the ONLINE operational state.

In addition to the necessary users, volumes and so on, an initial backup template called INITIALBACKUP is created and data is backed up to this template. To create additional backup templates, proceed as described in Managing the Backup Templates [Seite 42]. To carry out additional backups, proceed as described in Backup Procedures [Seite 46].

---

### Initializing an Existing Database Instance

You can use the Database Manager GUI to initialize an existing database on a local or remote computer.

⚠️ When you initialize a database instance, all the data is deleted.

However, you can keep your database parameters and the configuration of your volumes and backup templates.
Prerequisites

- You have administrator rights for the database instance. This is guaranteed automatically if you log on as the first DBM operator.

- Database instance on a **local computer**: You have administrator rights for the computer as an operating system user.

- Database instance on a **remote computer**: You have an operating system user for the remote computer with administrator rights and also the *log on as batch job* right (for Microsoft Windows operating systems) or a similar right (information on managing operating system users is provided in the documentation for your operating system).

Procedure

Select the required database instance in the list of database instances [Seite 16].

Choose *Instance → Initialize...*.  
Choose *Next* to start each of the required steps.

1. Choose *Initialize the database instance <database_name>*.  
   An empty database instance is created under the existing name (the database instance is initialized and all of the data from the previous version is lost).

2. If necessary, transfer the database instance to the ADMIN operational state.

3. Choose *Use current parameters*.

4. The database parameters you configured for the database instance are proposed. In other words, you do not have to change them.

5. The volumes you configured for the database instance are proposed. In other words, you do not have to change them.

6. The backup templates you configured for the database instance are proposed. In other words, you do not have to change them.

7. Choose from the following options:
   
   - *Create and start instance*  
     Specify the database system administrator (SYSDBA user). The database instance is initialized and transferred to the ONLINE operational state.

   - *Create instance for recovery*  
     The database instance is initialized and transferred to the ADMIN operational state. You can use this database instance for a *restore [Seite 52]* only. The details for the database system administrator are taken from the data backup.

8. Choose *Start*.

9. Choose *Close*.

Database Instance Management

The table below provides you with links to descriptions of various database management tasks:

<table>
<thead>
<tr>
<th>Creating, initializing or deleting a database instance</th>
<th>Creating a database instance [Seite 9]</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Initializing an Existing Database Instance [Seite 13]</td>
</tr>
<tr>
<td></td>
<td>Deleting a Database Instance [Seite 30]</td>
</tr>
<tr>
<td>Feature</td>
<td>Reference</td>
</tr>
<tr>
<td>----------------------------------------------</td>
<td>-----------------------------------------------</td>
</tr>
</tbody>
</table>
| Displaying, creating, changing, or deleting the list of database instances | Screen Areas of the Database Manager GUI [Seite 8]  
                                         | Managing the List of Database Instances [Seite 16] |
| Creating a database instance connection to the DBM Server | Connection to the DBM Server [Seite 16] |
| Starting or stopping the database instance    | Starting (Restarting) the Database Instance [Seite 17]  
                                         | Stopping the Database Instance (Shutdown) [Seite 18] |
| Backing up or restoring a database instance  | Backup [Seite 41]  
                                         | Restore [Seite 52] |
| Monitoring database sessions                 | Monitoring the Operating Status [Seite 18]  
                                         | Displaying Database Sessions [Seite 67]  
                                         | Closing a Database Session Manually [Seite 19] |
| Create, display, change, or delete a user    | Managing the Database System Administrator [Seite 30]  
                                         | Managing Database Manager Operators [Seite 33]  
                                         | Managing Database Users [Seite 37] |
| Creating, displaying, changing, or deleting volumes | Creating, displaying and deleting volumes [Seite 20]  
                                         | Changing Volume Properties [Seite 21]  
                                         | Displaying Data Area Information [Seite 64]  
                                         | Displaying Log Area Information [Seite 68]  
                                         | Switching on/off Automatic Extension of the Data Area [Seite 23] |
| Displaying and changing database parameters  | Displaying and Changing Database Parameters [Seite 22]  
                                         | Changing Database Parameters for Volumes [Seite 22] |
| Displaying and changing log settings         | Displaying Log Area Information [Seite 68]  
                                         | Changing Log Settings [Seite 24] |
| Setting up a hot standby system              | Setting Up a Master Instance (Hot Standby) [Seite 25]  
                                         | Adding a Standby Instance (Hot Standby) [Seite 26] |
| Activating, deactivating, or deleting indexes | Activating, Deactivating, or Deleting Indexes [Seite 26] |
| Language support (MapChar sets)              | Creating, Displaying, Changing and Deleting Mapchar Sets [Seite 27] |
| Updating statistics                          | Updating Statistical Information [Seite 28] |
| Loading demo data                            | Creating a Database Instance: Desktop PC/Laptop [Seite 10]  
                                         | Loading Demo Data [Seite 29] |

**See also:**

Displaying Information [Seite 62]  
Diagnosis Options [Seite 69]
Managing the List of Database Instances

Before you can use the Database Manager GUI to manage your database instances, you must include these instances in the list of database instances (see Screen Areas [Seite 8]). You can change the way the database instances are displayed in this list by choosing View → ...

Prerequisites

If you want to access a remote database instance with the Database Manager, you have to start the X Server on the relevant database computer.

Procedure

Adding an Entry to the List of Database Instances

1. Choose Instance → Add.
2. Choose the required server name as the Database Server. Confirm this by choosing Add.
3. Select the database instances that you want to include in the list, and confirm.

The database instance is included in the list of database instances.

To be able to manage a database instance, you must set up a connection to the DBM server [Seite 16] for this instance.

Deleting an Entry from the List of Database Instances

1. Select the database instance in the list of database instances [Seite 8].
2. Choose File → Delete.
3. Confirm that you want to delete this database instance from the list.

The database instance is deleted from the list of database instance in the Database Manager.

If you want to delete a database instance, proceed as described under Deleting a Database Instance [Seite 30].

Synchronizing the Database Instance List in the Database Manager with the Existing Database Instances

You can make sure that the list of database instances matches the instances that actually exist on the computer.

1. Select a computer in the directory structure of the database instances [Seite 8].
2. Choose File → Sync Server.

All database instances on this computer are included in the list of database instances. Any entries for database instances that no longer exist on this computer are deleted from the list.

Connection to the DBM Server

To manage database instances using the Database Manager GUI program, the database instance that is to be managed needs to be to be connected to your DBM Server.

You can set up the connection to the DBM Server for one, more than one, or all database instances displayed in the list, depending on the performance of your system. Similarly, you
can terminate the connection between individual database instances and your DBM Server to reduce the load on your system.

Prerequisites
The required database instance must be included in the list of the database instances [Seite 8]. To do this, proceed as described in Managing the List of Database Instances [Seite 16].

Procedure

Connecting a Database Instance to the DBM Server

The State of the database instance is Not connected.

6. Select the database instance in the list of database instances.
7. Choose Instance → Connect.
8. Enter the name and password of the Database Manager operator if necessary. You can save this information.

The Database Manager can now determine the current operational state of the selected database instance.

Terminating a Connection Between a Database Instance and the DBM Server

9. Select the database instance in the list of database instances.
10. Choose Instance → Disconnect.

The State of this database instance is now Not connected.

The connection to the DBM Server has been terminated. The Database Manager can no longer determine the operational state of the database instance and thus cannot perform analyses of the database instance.

Starting (Restarting) the Database Instance

You can use the Database Manager GUI to start a database instance.

Prerequisites

11. Make sure that the database instance has been included in the list of database instances (see Managing the List of Database Instances [Seite 16]).
12. Set up the connection to the DBM server [Seite 16].
13. Determine the operational state of the database instance: Monitoring the Operational State [Seite 18].

Procedure

Select a database instance in the list of database instances by double-clicking it.

The database instance is in the OFFLINE operational state.

- Transferring the database instance to the operational state ONLINE
  Choose Actions → Online.
  The database instance starts.
- Transferring the database instance to the operational state ADMIN
  Choose Actions → Admin.
  The database instance is transferred to the operational state ADMIN.
The database instance is in the ADMIN operational state.

- Transferring the database instance to the operational state ONLINE
  Choose Actions → Online.
  The database instance starts.

  Each time you start the database, the system creates a copy of the log file, which is then overwritten.

See also:
Stopping the Database Instance (Shutdown) [Seite 18]

Stopping the Database Instance (Shutdown)

You can use the Database Manager GUI to stop a database instance.

Prerequisites
14. Make sure that the database instance has been included in the list of database instances (see Managing the List of Database Instances [Seite 16]).
15. Set up the connection to the DBM server [Seite 16].
16. The database instance is in the ONLINE operational state: Monitoring the Operational State [Seite 18].

Procedure
Select a database instance in the list of database instances by double-clicking it.

- Transferring the database instance to the operational state ADMIN
  Choose Actions → Admin.
  The database instance is transferred to the operational state OFFLINE and then to the operational state ADMIN. Any changes made to the database parameters take effect.

- Transferring the database instance to the operational state OFFLINE
  Choose Actions → Offline.
  The database instance is stopped.

  If a backup is running, the Database Manager waits until the backup is complete before stopping the database instance.

  Use the kernel log to analyze any errors that occurred when you started or stopped the database instance.

See also:
Starting (Restarting) the Database Instance [Seite 17]

Monitoring the Operational State

You can use the Database Manager GUI to monitor the operational state of each database instance.
**Prerequisites**

17. Make sure that the database instance has been included in the list of database instances (see Managing the List of Database Instances [Seite 16]).

18. Set up the connection to the DBM server [Seite 16].

**Displaying the Operational State**

Check the indicator assigned to the general icon for the database instance in the list of database instances.

You can use displays View → Large Icons/Small Icons/List for this purpose.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="General database instance icon" /></td>
<td>General database instance icon</td>
</tr>
<tr>
<td><img src="image" alt="Database instance is in the OFFLINE operational state" /></td>
<td>Database instance is in the OFFLINE operational state</td>
</tr>
<tr>
<td><img src="image" alt="Database instance is in the ADMIN operational state" /></td>
<td>Database instance is in the ADMIN operational state</td>
</tr>
<tr>
<td><img src="image" alt="Database instance is in the ONLINE operational state" /></td>
<td>Database instance is in the ONLINE operational state</td>
</tr>
</tbody>
</table>

Hot standby database instances have the following icons:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Master instance or standby instance is in the OFFLINE operational state." /></td>
<td>Master instance or standby instance is in the OFFLINE operational state.</td>
</tr>
<tr>
<td><img src="image" alt="Master instance is in the ADMIN operational state or standby instance is in the STANDBY operational state." /></td>
<td>Master instance is in the ADMIN operational state or standby instance is in the STANDBY operational state.</td>
</tr>
<tr>
<td><img src="image" alt="Master instance is in the ONLINE operational state." /></td>
<td>Master instance is in the ONLINE operational state.</td>
</tr>
</tbody>
</table>

**Changing the Operational State**

Select a database instance in the list of database instances by double-clicking it.

Choose Actions → OFFLINE / ADMIN / ONLINE to change to the relevant operational state.

⚠️ You cannot change the operational state of standby instances in a hot standby system directly. Standby instances are controlled by the master instance.

**See also:**

Starting (Restarting) the Database Instance [Seite 17]
Stopping the Database Instance (Shutdown) [Seite 18]

**Closing a Database Session Manually**

**Use**

In certain cases, it may be necessary to terminate an individual database session manually.

**Prerequisites**

The database instance is in the ONLINE operational state.

**Procedure**
1. Select the required database instance in the list of database instances [Seite 8].
2. Choose Instance → Sessions.
3. Select the database session that you want to close.
4. Choose Actions → Kill Selected Sessions to close the database session.

See also:
Displaying Database Sessions [Seite 67]

Creating, Displaying and Deleting Volumes

You can use the Database Manager GUI to increase the storage capacity of your data area or log area.

- The maximum number of data volumes you can create is defined in the general database parameter MaxDataVolumes.
- The maximum number of log volumes you can create is defined in the general database parameter MaxLogVolumes.
- You can delete data volumes.

Prerequisites

The database instance is in the ONLINE operational state.

If you want to create new volumes, the value of the database parameter MaxDataVolumes or MaxLogVolumes must at least equal the total number of existing volumes plus the new volumes you want to define.

Every time the database instance is started, the system checks that there is enough space available for at least one volume of each type. If there is not, it automatically increases the setting of the appropriate database parameter by 1.

If necessary, change the database parameter MaxDataVolumes or MaxLogVolumes accordingly (see Changing Database Parameters for Volumes [Seite 22]). This will enable you to add a volume of the given type a number of times in succession with the database instance in the ONLINE operational state without having to stop the database instance.

Procedure

Select the required database instance in the list of database instances (Managing the List of Database Instances [Seite 16]).

Choose Instance → Configuration → Volumes.

The system displays all existing volumes of the selected type and their data, as well as the maximum number of volumes still possible according to the parameter value.

<table>
<thead>
<tr>
<th>Name</th>
<th>Name of the volume</th>
</tr>
</thead>
<tbody>
<tr>
<td>Size</td>
<td>Size of the volume</td>
</tr>
<tr>
<td>Type</td>
<td>File, raw device, or symbolic link</td>
</tr>
<tr>
<td>Device/File</td>
<td>Device/path and file name of the volume</td>
</tr>
<tr>
<td>M. Type</td>
<td>File, raw device, or symbolic link (mirrored volume)</td>
</tr>
<tr>
<td>M. Location</td>
<td>Path of the mirrored log volume</td>
</tr>
</tbody>
</table>
Creating a volume
2. Define the new volume by specifying the size under Size and the device or path and file name of the volume under Device/File.
3. Choose OK.

Deleting a data volume
4. Select the data volume you want to delete.
5. Choose Actions → Delete.
6. Confirm that you want to delete this data volume.

See also:
Changing Volume Properties [Seite 21]
Switching on/off Automatic Extension of the Data Area [Seite 23]

Changing Volume Properties
You can use the Database Manager GUI to change volume properties.

Prerequisites
The database instance is in the OFFLINE operational state.
You have copied the log or data volume to a new location and you want to inform the Database Manager GUI of the path to the new location.

Procedure
1. Select the required database instance in the list of database instances [Seite 8].
2. Choose Instance → Configuration → Volumes.
   All the existing volumes of the selected type are displayed.

<table>
<thead>
<tr>
<th>Name</th>
<th>Name of the volume</th>
</tr>
</thead>
<tbody>
<tr>
<td>Size</td>
<td>Size of the volume</td>
</tr>
<tr>
<td>Type</td>
<td>File, raw device, or symbolic link</td>
</tr>
<tr>
<td>Device/File</td>
<td>Device/path and file name of the volume</td>
</tr>
<tr>
<td>M. Type</td>
<td>File, raw device, or symbolic link (mirrored volume)</td>
</tr>
<tr>
<td>M. Location</td>
<td>Path of the mirrored log volume</td>
</tr>
</tbody>
</table>

3. Select the volume you want to change.
5. Specify the device or path and file name of the volume under Device/File.
6. Choose OK.

When you now restart the database instance [Seite 17] the database system will know the new path.

See also:
Creating, Displaying and Deleting Volumes [Seite 20]
### Displaying and Changing Database Parameters

You can use the Database Manager GUI to display and change the database parameters of the current database instance. You can do this in any operational state of the database instance.

The changes to database parameters do not take effect until the database instance is restarted [Seite 17].

You can also change some database parameters while the database is running. In addition you can choose how long the change is to be effective for these database parameters.

#### Procedure

1. Choose **Instance → Configuration → Parameters**.

   The database parameters are displayed. They are divided into three groups:
   - General Database Parameters (General)
   - Special Database Parameters (Extended)
   - Support Database Parameters (Support)

2. Choose the database parameters you want.

3. Choose **Action → Properties**.

4. Enter the new value of the database parameter under **New Value**.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of the database parameter</td>
</tr>
<tr>
<td>Value</td>
<td>Current value of the database parameter</td>
</tr>
<tr>
<td>New value</td>
<td>New value of the database parameter</td>
</tr>
<tr>
<td>Comment</td>
<td>User-defined comment</td>
</tr>
<tr>
<td></td>
<td>This comment is displayed in the history of the database parameters. See Displaying Database Parameters [Seite 67]</td>
</tr>
<tr>
<td>Durability</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Permanent: Change is permanent</td>
</tr>
<tr>
<td></td>
<td>• Running: Change is immediately effective</td>
</tr>
<tr>
<td>Description</td>
<td>Help text on the selected parameter</td>
</tr>
</tbody>
</table>

5. Confirm your entries.

### Changing Database Parameters for Volumes

You can use the Database Manager GUI to define database parameters, including those that define the maximum number of volumes in a database instance: the general database parameters `MaxDataVolumes` and `MaxLogVolumes`.

You can change the settings of both database parameters at a later date regardless of which operational state the database instance is in. These database parameter changes take effect the next time the database instance is restarted.

#### Procedure
1. For the database parameters `MaxDataVolumes` and `MaxLogVolumes`, proceed as described in Displaying and Changing Database Parameters [Seite 22].

2. Start the database instance again.

The Database Manager GUI switches the database instance to the OFFLINE operational state before switching it back to the ONLINE operational state, saving the new value of the database parameter in the parameter file.

The Database Manager GUI reserves the memory required by this number of volumes, plus reserve memory large enough for the largest volume of this type. This reserve allows you to create an additional volume of this type while the database is running if the original number of volumes is not enough.

**See also:**
Creating, Displaying and Deleting Volumes [Seite 20]

### Switching on/off Automatic Extension of the Data Area

You can configure your database system in such a way that it automatically adds a new data volume as soon as the fill level of the data area reaches a certain percentage. To do this, you can switch on automatic extension of the data area using the Database Manager GUI.

#### Prerequisites

The database instance is in the ONLINE operational state.

A separate event task is required for this function. Ensure therefore that the `FloatingServiceTasks` and `PreservedEventTasks` database parameter values are sufficiently large.

If you switch on automatic extension of the data area, the last data volume that you have added must be of the type file.

You can activate automatic extension of the data area when creating a database instance (Creating a Database Instance: Custom [Seite 11]).

#### Procedure

**Switching on Automatic Extension of the Data Area**

1. Choose `Instance → Data Area Extension`.
2. Enter the filling level at which a new data volume should be added to the data area as a percentage.
3. Choose `On`.

When you activate this function, you can specify a percentage value at which a data volume should be added. If you do not specify a percentage value, the system will add a data volume when the fill level reaches 90%. You can overwrite the defined value by executing the function again using a different value.

The number of data volumes that can be added while the database is in operation is limited by the value of the `MaxDataVolumes` database parameter.

The system uses existing volume definitions to determine a default name for the new data volume. This name is then used.

**Switching off Automatic Extension of the Data Area**
1. Choose Instance → Data Area Extension.

2. Choose Off.

You should monitor the fill level of the data area regularly as this is not done automatically: Displaying Data Area Information [Seite 64].

Extend the data area in good time (Creating, Displaying and Deleting Volumes [Seite 20]) or activate automatic extension of the database again.

See also:

Displaying and Changing Database Parameters [Seite 22]

Changing Database Parameters for Volumes [Seite 22]

Changing Log Settings

You can use the Database Manager GUI to change log settings.

Prerequisites

Decide the level of security you need and read about the possible log settings.

You can make some log settings when creating a database instance (Creating a Database Instance: Custom [Seite 11]).

Check the log area information [Seite 68] regularly in the Database Manager GUI.

Procedure

Select the required database instance in the list of database instances (Managing the List of Database Instances [Seite 16]). Choose Instance → Configuration → Log Settings.

Choose Next to start each of the required steps.

1. Select the log setting that you want to change:
   ○ Log Mode: Mirrors the log area
   ○ Overwrite Mode for the Log Area: activates and deactivates the overwrite mode for the log area
   ○ Activating or Deactivating the Redo Log Management: activates and deactivates the redo log management

2. You can change multiple log settings in succession. To do so, choose Back each time you complete your change.

Mirroring the Log Area

If you want to mirror the log area, select the log setting Log Mode.

The database instance can be in any operational state. Make sure, however, that you change the database instance into the OFFLINE operational state after setting the log mode, and then into the ONLINE operational state.

The Database Manager prompts you to create the required mirrors of the log volumes.

1. Choose Properties.

2. Specify the location of the mirror under Location.

3. Start the process.

After this operation has been completed, the database instance is changed to the OFFLINE operational state and then to ONLINE.
If you no longer want to use the mirror, select the Log Mode log setting and follow the instructions.

**Overwrite Mode for the Log Area**

If your security concept allows you to overwrite the log area without backing up the log entries first, select the log setting **Overwrite Mode for the Log Area** and follow the instructions.

After a standard installation, normal log backups are activated, which means that the overwrite mode is deactivated. Before you can change the overwrite mode, the database instance must be in the ADMIN or ONLINE operational state.

Once you have activated overwrite mode, it remains activated even if the database is restarted.

To change back to normal log backups (and deactivate the overwrite mode), select **Overwrite Mode for the Log Area** and follow the instructions. You are prompted to make a complete data backup to guarantee the integrity of your data.

**Activating and Deactivating Redo Log Management**

Under exceptional circumstances, you have the option of deactivating redo log management. To do so, select the log setting **Activating or Deactivating the Redo Log Management** and follow the instructions.

Redo log management is activated after a standard installation. Before you can change this log setting, the database instance must be in the ADMIN operational state.

Once you have deactivated redo log management, it remains deactivated even if the database is restarted.

You must reactivate redo log management as soon as possible to guarantee the integrity of your database system. To do so, select **Activating or Deactivating the Redo Log Management** and follow the instructions. You are prompted to make a complete data backup to guarantee the integrity of your data.

**Setting Up a Master Instance (Hot Standby)**

You can use the Database Manager GUI to set up the master instance of a hot standby system.

**Prerequisites**

You are connected to the database instance of the hot standby system on the virtual server.

**Procedure**

In the Database Manager GUI, choose *Instance* → *Configuration* → *Hot Standby*.

Choose *Next* to start each of the required steps.

1. Choose **Enable or Disable the Hot Standby System**.
2. Choose **Enable Hot Standby System**.
3. For **Virtual Server Name**, enter the name that the system administrator has defined for the computer on which the master instance is located.
4. Under **Storage DLL**, enter the name of the library used to address the memory management system.
5. Choose **Start**.

**See also:**

*Adding a Standby Instance (Hot Standby)* [Seite 26]
Adding a Standby Instance (Hot Standby)

With the Database Manager GUI, you can add a standby instance to a hot standby system.

Prerequisites

- You have already set up the master instance of the hot standby system.
- You are connected to the database instance of the hot standby system on the virtual server.

Procedure

On the Database Manager GUI, choose Instance → Configuration → Hot Standby.

Choose Next to start each of the required steps.

1. Choose Add or Remove Standby Instances.
2. Choose Add Standby Instance. Make the following entries:

<table>
<thead>
<tr>
<th>Node</th>
<th>Name of the standby computer</th>
</tr>
</thead>
<tbody>
<tr>
<td>Login Name</td>
<td>Operating system user on the standby computer</td>
</tr>
<tr>
<td>Password</td>
<td>Password of the operating system user on the standby computer</td>
</tr>
<tr>
<td>Installation</td>
<td>Installation path of the database software on the standby computer</td>
</tr>
<tr>
<td>Delay</td>
<td>Delay (in seconds) until the standby instance redoes the changes in the master instance.</td>
</tr>
</tbody>
</table>

3. Choose Start.

You have added the standby instance and put it in the STANDBY operational state.

See also:

Setting Up a Master-Instance (Hot Standby) [Seite 25]

Database Administration, Hot standby [Extern]

Activating, Deactivating, or Deleting Indexes

You can use the Database Manager GUI to determine which of the existing indexes have been used in a database instance.

You can also activate, deactivate, or delete selected indexes.

Prerequisites

The database instance is in the ONLINE operational state.

Procedure

Select the required database instance in the list of database instances [Seite 8].

1. Choose Instance → Tuning → Index Use.
2. You can choose which indices are to be displayed. To do this, enter appropriate search arguments:

| Owner | Owner |
You can also choose between the following options:

<table>
<thead>
<tr>
<th>Table Name</th>
<th>Name of the table</th>
</tr>
</thead>
<tbody>
<tr>
<td>Index Name</td>
<td>Name of the index</td>
</tr>
</tbody>
</table>

3. Choose Actions → Search. A list of the indices that match your criteria is then displayed.

4. Select the indexes that you want to activate.
   If you want to activate all of the indexes displayed, choose Actions → Mark All.
   Select the indices you want to deactivate in the list.

5. Choose Actions and the action you want to perform.

See also:
Reverting the Indexes After Database Restore [Seite 59]

---

Creating, Displaying, Changing and Deleting MapChar Sets

You can use the Database Manager GUI to create, display, change and delete MapChar sets.

**Prerequisites**

The database instance is in the ONLINE operational state.

**Procedure**

Select the required database instance in the list of database instances [Seite 8].

Select Instance → Configuration → Mapchar Sets.

You are shown the MapChar sets which are already available.

**Creating MapChar Sets**

1. Choose Actions → New.
2. Enter the following information:

<table>
<thead>
<tr>
<th>Name</th>
<th>Name of MapChar set (name must not be more than 18 bytes long)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Code type</td>
<td>The code on which the MapChar set is based. ASCII</td>
</tr>
<tr>
<td>Mapchar</td>
<td>Define the conversions for the characters required. Each one-byte (ASCII) or two-byte (UNICODE) character to be converted must first be specified in its original form and then in the target form with a maximum length of two bytes (ASCII) or four bytes (UNICODE). Intern: Original form in hexadecimal format Extern Hex: Target form in hexadecimal format Ext. ASCII: Target form in printable characters (not possible for UNICODE)</td>
</tr>
</tbody>
</table>

3. Save your entries.
Changing MapChar Sets
4. Select the MapChar set you require.
5. Choose Actions → Properties.
6. Make the desired changes.
7. Save your entries.

Deleting MapChar Sets
8. Select the MapChar set you require.
9. Choose Actions → Delete.
10. Confirm you want to delete the MapChar set.

Updating the Statistics Information
You can use the Database Manager GUI to update the SQL Optimizer statistics. Additionally, you can also automate this process.

Prerequisites
The database instance is in the ONLINE operational state.

Updating Statistics Information Manually
1. Select the required database instance in the list of database instances [Seite 8].
   Choose Instance → Tuning → Optimizer Statistics.
2. Create a list of the tables for which the statistics are to be updated:
   ○ To select all the tables for which an update is necessary, apply the default value "*" under Search.
   ○ To select certain tables for which an update is necessary, enter the corresponding search arguments under Search.

<table>
<thead>
<tr>
<th>Search Argument</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Owner</td>
<td>Owner</td>
</tr>
<tr>
<td>Table Name</td>
<td>Table name</td>
</tr>
<tr>
<td>Column Name</td>
<td>Name of column</td>
</tr>
</tbody>
</table>

   ○ To select all tables for which an update of statistics is possible irrespective of whether or not they need to be updated, under Advanced choose the option Select from tables.
3. Choose Actions → Search.
   A list of the tables is displayed that matches your criteria under Search and Advanced.
   From the Update Statistics Date and Update Statistics Time columns, you can tell when the statistics for this table were last updated.
4. From the list of tables, choose the tables for which you want to update the statistics.
5. You have the following options when updating the statistics:
   ○ Updating the statistics for all rows of the selected tables (system default)
   ○ Updating the statistics for a sample
To define the sample, enter the corresponding parameter under *Estimate*.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Use estimate value</em></td>
<td>Defines whether a sample is to be used</td>
</tr>
<tr>
<td><em>Percent</em></td>
<td>Percentage of table rows to be checked</td>
</tr>
</tbody>
</table>

To exclude a table from the updating of statistics, you select the value 0 for the sample size for this table.

SAP customers can find more information in SAP Note 808060.

- If you want to update the column statistics in addition to the table statistics, choose the option *Include update columns for marked tables* under *Advanced*, double-click the desired table in the list and then choose the desired columns.

6. Choose *Actions* → *Execute*.

**Switching Automatic Update of Statistics Information On-/Off**

You can switch on/off automatic update of statistics information automatically when creating a database instance. To do this, proceed as described in *Adding a Database Instance: Custom*.

If you want to switch this option on/off at a later date, use the following Database Manager GUI function:

1. Select the required database instance in the list of database instances. Choose *Instance* → *Automatic Statistics Update*.
2. Choose *On* or *Off*.

**Loading Demo Data**

You can use the Database Manager GUI to load all the demo data.

**Prerequisites**

The database instance is in the ONLINE operational state.

**Procedure**

1. Select the required database instance in the list of database instances. Choose *Instance* → *Configuration* → *Load Tutorial*.
2. Confirm you wish to load the demo data.

**Result**

The demo data is newly created in the database instance. Any existing demo data is overwritten.

- You can load the demo data directly when you create a database instance. To do this, proceed as described in *Adding a Database Instance: Desktop PC/Laptop*.
**Deleting a Database Instance**

You can use the Database Manager GUI to delete a database instance.

When you do so, you can also specify whether the database files on the DBM Server should be deleted.

**Prerequisites**

You have set up the connection to the DBM Server [Seite 16].

The database instance is in the OFFLINE operational state.

**Procedure**

1. Select the database instance in the list of database instances [Seite 8].
2. Choose **Instance → Drop**.
3. If you do not want to delete the database files, deselect the *Delete database files* field.
4. Confirm that you want to delete this database instance.

---

**Managing the Database System Administrator**

You can use the Database Manager GUI to manage the database system administrator (SYSDBA user).

**Activities**

The **database system administrator (SYSDBA user)** [Seite 9] is generated when the database instance is created.

You can perform the following administration tasks with the Database Manager GUI:

- Changing the DBM Operator Properties of the Database System Administrator [Seite 30]
- Changing the Password of the Database System Administrator [Seite 31]
- Changing the Server Authorizations of the Database System Administrator [Seite 32]
- Changing the SQL User Properties of the Database System Administrator [Seite 32]

**See also:**

- Managing Database Manager Operators [Seite 33]
- Managing Database Users [Seite 37]

---

**Changing the DBM Operator Properties of the Database System Administrator**

You can use the Database Manager GUI to change the DBM operator properties of the database system administrator (SYSDBA user).

**Prerequisites**

The user has the *Managing DBM Operators (User management)* server authorization.
If you want to change the password of the database system administrator, the database instance must be in the ONLINE operational state.

**Procedure**

1. Choose *Instance → Configuration → DBM Operator...*.
2. Select the database system administrator.
3. Choose *Properties*.
4. Choose the *General* tab page and change the desired DBM operator properties.

### DBM Operator Properties

<table>
<thead>
<tr>
<th>General</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Password</strong></td>
<td>You can change the password of the database system administrator.</td>
</tr>
<tr>
<td><strong>Disabled</strong></td>
<td>Set this option when you want to lock the database system administrator.</td>
</tr>
<tr>
<td><strong>Enable Pwd</strong></td>
<td>Set this option if you want to enter a second password for the database system administrator.</td>
</tr>
</tbody>
</table>

**Result**

The database system administrator has the DBM operator properties you set.

**See also:**
- Changing the Password of the Database System Administrator [Seite 31]
- Managing the Database System Administrator [Seite 30]

---

### Changing the Password of the Database System Administrator

You can use the Database Manager GUI to change the password of the database system administrator (SYSDBA user).

**Prerequisites**

The database instance is in the ONLINE operational state.

⚠️ Pay attention to the conventions for user names and passwords.

The database system automatically converts passwords into upper-case letters.

Choose one of the following procedures:

**Procedure 1**

1. Choose *Instance → Configuration → DBM Operator...*.
2. Select the database system administrator.
3. Choose *Properties*.
4. Select the tab page *General* and then choose *Password Change*.
5. Enter the old and new passwords and save your entries.
Procedure 2

6. Choose Instance → Configuration → Database User…
7. Enter the name and password of the database system administrator.
8. Select the database system administrator.
10. Select the tab page General and then choose Password Change.
11. Enter the old and new passwords and save your entries.

Result
The password of the database system administrator is changed.

See also:
Managing the Database System Administrator [Seite 30]

chéanging the Server Authorizations of the Database System Administrator
You can use the Database Manager GUI to change the server authorizations of the database system administrator (SYSDBA user).

Prerequisites
The user has the Managing DBM Operators (User management) server authorization.

Procedure

1. Choose Instance → Configuration → DBM Operator…
2. Select the database system administrator.
3. Choose Properties.
4. On the Server Rights tab page, you can now extend or limit the server authorizations of the selected user by selecting or deselecting the required authorizations.

Result
The server authorizations of the database system administrator are set according to your wishes.

chéanging the SQL User Properties of the Database System Administrator
You can use the Database Manager GUI to change the SQL user properties of the database system administrator.

Prerequisites
The database instance is in the ONLINE operational state.

Procedure
1. Choose Instance → Configuration → Database User...
2. Enter the name and password of the database system administrator.
3. Select the database system administrator.
5. Choose the General tab page and change the desired SQL user properties.

**SQL User Properties**

<table>
<thead>
<tr>
<th>General</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Password Change</td>
<td>You can change the password of the database system administrator.</td>
</tr>
<tr>
<td>Connection Mode</td>
<td>You can set the following connection modes:</td>
</tr>
<tr>
<td></td>
<td>The database user can open several database sessions at once (NOT EXCLUSIVE).</td>
</tr>
<tr>
<td></td>
<td>Each database user can open only one database session (EXCLUSIVE).</td>
</tr>
<tr>
<td></td>
<td>The database user may not open any database sessions (DISABLED).</td>
</tr>
</tbody>
</table>

6. Choose the Extended tab page and change the desired SQL user properties.

**SQL User Properties**

<table>
<thead>
<tr>
<th>Extended</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Timeout</td>
<td>You can set the timeout value.</td>
</tr>
<tr>
<td>Cost Warning</td>
<td>You can set the estimated SELECT cost value above which a warning is issued.</td>
</tr>
<tr>
<td>Cost Limit</td>
<td>You can set the estimated SELECT cost value above which an SQL statement is not executed.</td>
</tr>
<tr>
<td>Default Code</td>
<td>You can set a default value for the code attribute.</td>
</tr>
</tbody>
</table>

**Result**

The database system administrator has the SQL user properties you set.

See also:

- Changing the Password of the Database System Administrator [Seite 31]
- Managing the Database System Administrator [Seite 30]

**Managing Database Manager Operators**

You can use the Database Manager GUI to manage Database Manager operators (DBM operators).

**Activities**

A Database Manager operator with all server authorizations is generated when you create a new database instance [Seite 9]. You can create more Database Manager operators and assign them the server authorizations you want them to have.

You can use the Database Manager GUI to perform the following administration actions for Database Manager operators:

- Creating, Changing, or Deleting a Database Manager Operator [Seite 34]
Creating, Changing, or Deleting a Database Manager Operator

You can use the Database Manager GUI to create a Database Manager operator (DBM operator), change the operator’s properties and server authorizations, or delete the operator.

Prerequisites

The user has the *Managing DBM Operators* (*User management*) server authorization.

Creating a Database Manager Operator

1. Choose *Instance* → *Configuration* → *DBM Operator*…
2. Choose *New User*.
3. Choose the *General* tab page and enter the desired DBM operator properties.

### DBM Operator Properties

<table>
<thead>
<tr>
<th>General</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Enter the name of the new Database Manager operator.</td>
</tr>
<tr>
<td>Password</td>
<td>Enter a password for this Database Manager operator.</td>
</tr>
<tr>
<td>Confirm Password</td>
<td>Confirm the new password.</td>
</tr>
<tr>
<td>Comment</td>
<td>You can enter a description of the operator.</td>
</tr>
<tr>
<td>Disabled</td>
<td>Set this option when you want to lock the Database Manager operator.</td>
</tr>
<tr>
<td>Enable Pwd</td>
<td>Set this option if you want to enter a second password for the Database Manager operator.</td>
</tr>
</tbody>
</table>

Pay attention to the conventions for user names and passwords. The database system automatically converts user names and passwords for DBM operators into upper-case letters.

4. Choose the *Server Rights* tab page.
   Choose the desired server authorizations for the DBM server.

Changing a Database Manager Operator

You can change the properties and server authorizations of a Database Manager operator.

To change the DBM operator properties and server authorizations, proceed as described in the following sections:

- Changing the DBM operator properties
- Changing the Password of a Database Manager Operator
- Changing the Server Authorizations

**Deleting a Database Manager Operator**

You can delete a DBM operator. The exception is the Database Manager operator (DBM operator) that is generated when a database instance is created.

5. Choose *Instance → Configuration → DBM Operator*.
6. Select a DBM operator.
7. Choose *Delete*.

**Changing the DBM Operator Properties**

You can use the Database Manager GUI to change the DBM operator properties of Database Manager operators (DBM operators).

**Prerequisites**

The user has the *User Management* server authorization.

**Procedure**

1. Choose *Instance → Configuration → DBM Operator*.
2. Select a DBM operator.
3. Choose *Properties*.
4. Choose the *General* tab page and change the desired properties.

**DBM Operator Properties**

<table>
<thead>
<tr>
<th>General</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Password</em></td>
<td>You can change the password of the Database Manager operator.</td>
</tr>
<tr>
<td><em>Comment</em></td>
<td>You can change the description of the Database Manager operator.</td>
</tr>
<tr>
<td><em>Disabled</em></td>
<td>Set this option when you want to lock the Database Manager operator.</td>
</tr>
<tr>
<td><em>Enable Pwd</em></td>
<td>Set this option if you want to enter a second password for the Database Manager operator.</td>
</tr>
</tbody>
</table>

**Result**

The Database Manager operator has the DBM operator properties you set.

**See also:**

- Changing the Password of a DBM Operator [Seite 36]
- Managing Database Manager Operators [Seite 33]
### Changing the Password of a Database Manager Operator

You can use the Database Manager GUI to change the passwords of Database Manager operators (DBM operators).

#### Prerequisites

The user has the *Managing DBM Operators (User management)* server authorization.

#### Procedure

1. Choose *Instance → Configuration → DBM Operator...*.
2. Select a DBM operator.
3. Choose *Properties*.
4. Select the tab page *General* and then choose *Password Change*.
5. Enter the old and new passwords and save your entries.

⚠️ Pay attention to the conventions for user names and passwords. The database system automatically converts passwords into upper-case letters.

#### Result

The password of the DBM operator is changed.

See also:

[Managing Database Manager Operators][1] 33

---

### Changing the Server Authorizations

You can use the Database Manager GUI to change the server authorizations of Database Manager operators (DBM operators).

#### Prerequisites

The user has the *Managing DBM Operators (User management)* server authorization.

#### Procedure

Choose *Instance → Configuration → DBM Operator...*.

Select a DBM operator.

Choose *Properties*.

On the *Server Rights* tab page, you can now extend or limit the server authorizations of the selected user by selecting or deselecting the required authorizations.

#### Result

The server authorizations of the DBM operator are set according to your wishes.

---

[1]: Managing Database Manager Operators [Seite 33]
Managing Database Users

You can use the Database Manager GUI to manage database users.

Prerequisites

The database instance is in the ONLINE operational state.

Activities

You can use the Database Manager GUI to perform the following administration actions for database users:

- Creating/Changing/Deleting a Database User [Seite 37]
- Changing the SQL User Properties of a Database User [Seite 39]
- Changing the Password of a Database User [Seite 40]
- Creating/Changing/Deleting a Synchronization User [Seite 40]

See also:

- Managing the Database System Administrator [Seite 30]
- Managing Database Manager Operators [Seite 33]

Creating/Changing/Deleting a Database User

You use the Database Manager GUI to create a database user, change the properties of a database user, or delete a database user.

Prerequisites

The database instance is in the ONLINE operational state.

Creating a Database User

1. Choose Instance → Configuration → Database User...
2. Enter the name and password of a database user of the database user class DBA, that is, a database administrator (DBA user).
   To create a database administrator (DBA user), enter the name and password of the database system administrator (SYSDBA user).
   To create a database user of the STANDARD or RESOURCE class, enter the name and password of the database system administrator (SYSDBA user) or a database administrator (DBA user).
3. Choose New User.
4. Choose the General tab page and enter the desired SQL operator properties.

SQL User Properties

<table>
<thead>
<tr>
<th>General</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Enter a name for the new database user.</td>
</tr>
<tr>
<td>Password</td>
<td>Enter a password for the new database user.</td>
</tr>
<tr>
<td>Confirm Password</td>
<td>Confirm the password.</td>
</tr>
<tr>
<td>User Class</td>
<td>Choose the database user class (DBA</td>
</tr>
</tbody>
</table>
Connection Mode

You can set the following connection modes:

- The database user can open several database sessions at once (NOT EXCLUSIVE).
- Each database user can open only one database session (EXCLUSIVE).
- The database user may not open any database sessions (DISABLED).

5. Choose the Extended tab page and enter the desired SQL user properties.

**SQL User Properties**

<table>
<thead>
<tr>
<th>Extended</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Timeout</td>
<td>You can set the timeout value.</td>
</tr>
<tr>
<td>Cost Warning</td>
<td>You can set the estimated SELECT cost value above which a warning is issued.</td>
</tr>
<tr>
<td>Cost Limit</td>
<td>You can set the estimated SELECT cost value above which an SQL statement is not executed.</td>
</tr>
<tr>
<td>Default Code</td>
<td>You can set a default value for the code attribute.</td>
</tr>
<tr>
<td>Replication User</td>
<td>Indicates whether the database user is the synchronization user.</td>
</tr>
</tbody>
</table>

Pay attention to the conventions for user names and passwords.

**Changing the SQL User Properties of a Database User**

You can change the SQL user properties of a database user. To do this, proceed as described in the following sections:

- Changing the SQL User Properties of a Database User [Seite 39]
- Changing the Password of a Database User [Seite 40]

**Deleting a Database User**

You can delete database users.

1. Choose Instance → Configuration → Database User... .
2. Select the desired database user.
3. Choose Delete.

Choose one of the following options:

- **Default**: The following are also deleted with the database user: all synonyms and tables that belong to this database user as well as all indexes, privileges, view tables, and so on, that are based on these synonyms and tables.
- **Restrict**: The database user is deleted only if he or she does not have any synonyms or tables.

See also:

Managing Database Users [Seite 37]
Changing the SQL User Properties of a Database User

You can use the Database Manager GUI to change the SQL user properties of a database user.

Prerequisites

The database instance is in the ONLINE operational state.

Procedure

1. Choose Instance → Configuration → Database User...

2. Enter the name and password of the database administrator that is the owner of the database user whose SQL user properties you want to change.

3. Select the desired database user.


5. Choose the General tab page and change the desired SQL user properties.

SQL User Properties

<table>
<thead>
<tr>
<th>General</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Password Change</td>
<td>You can change the password of the database user.</td>
</tr>
<tr>
<td>User class</td>
<td>You can change the database user class (DBA</td>
</tr>
<tr>
<td>Connection Mode</td>
<td>You can set the following connection modes:</td>
</tr>
<tr>
<td></td>
<td>• The database user can open several database sessions at once (NOT EXCLUSIVE).</td>
</tr>
<tr>
<td></td>
<td>• Each database user can open only one database session (EXCLUSIVE).</td>
</tr>
<tr>
<td></td>
<td>• The database user may not open any database sessions (DISABLED).</td>
</tr>
</tbody>
</table>

6. Choose the Extended tab page and change the SQL user properties as required.

SQL User Properties

<table>
<thead>
<tr>
<th>Extended</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Timeout</td>
<td>You can set the timeout value.</td>
</tr>
<tr>
<td>Cost Warning</td>
<td>You can set the estimated SELECT cost value above which a warning is issued.</td>
</tr>
<tr>
<td>Cost Limit</td>
<td>You can set the estimated SELECT cost value above which an SQL statement is not executed.</td>
</tr>
<tr>
<td>Default Code</td>
<td>You can set a default value for the code attribute.</td>
</tr>
<tr>
<td>Replication User</td>
<td>Indicates whether the database user is the synchronization user</td>
</tr>
<tr>
<td></td>
<td>For each database instance, there may only be one synchronization user</td>
</tr>
<tr>
<td></td>
<td>(Creating/Changing/Deleting the Synchronization User [Seite 40]).</td>
</tr>
</tbody>
</table>

Result

The database user has the SQL user properties you set.
Changing the Password of a Database User

You can use the Database Manager GUI to change the password of a database user.

**Prerequisites**

The database instance is in the ONLINE operational state.

**Procedure**

1. Choose *Instance → Configuration → Database User...*.
2. Enter the name and password of the database administrator that is the owner of the database user whose password you want to change.
3. Select the desired database user.
4. Choose *Properties*.
5. Select the tab page *General* and then choose *Password Change*.
6. Enter the old and new passwords and save your entries.

⚠️ Pay attention to the conventions for user names and passwords.

**Result**

The password of the database was changed.

**See also:**

*Managing Database Users [Seite 37]*

Creating/Changing/Deleting a Synchronization User

You can use the Database Manager GUI to create a synchronization user, change the SQL user properties of a synchronization user, or delete this user.

**Prerequisites**

The database instance is in the ONLINE operational state.

**Deleting Synchronization Users**

1. Choose *Instance → Configuration → Database User...*.
2. Enter the name and password of the database system administrator (SYSDBA user).
3. Choose *New User*.
4. Choose the *General* tab page and enter the following SQL user properties.

**SQL User Properties**
### General Description

<table>
<thead>
<tr>
<th>Name</th>
<th>Enter the name of the synchronization user.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Password</td>
<td>Enter the password for the synchronization user.</td>
</tr>
<tr>
<td>Confirm Password</td>
<td>Confirm the password for the synchronization user.</td>
</tr>
<tr>
<td>User Class</td>
<td>Use the database user class DBA</td>
</tr>
<tr>
<td>Connection Mode</td>
<td>Set NOT EXCLUSIVE as the connection mode (synchronization users can open multiple database sessions simultaneously).</td>
</tr>
</tbody>
</table>

5. Choose the *Extended* tab page and select the SQL user property *Replication User*.

Pay attention to the conventions for user names and passwords. Only one synchronization user can exist at any one time.

### Changing/Deleting Synchronization Users

The following SQL user properties for the synchronization user may **not** be changed.

- **User Class**
- **Connection Mode**
- **Replication User**

### Backup

#### Use

You can use the Database Manager GUI to back up a database instance. The database instance can be on a local computer or on a remote computer.

You can back up data from the data area and log entries from the log area on data carriers.

To perform backups in the background, use the Database Manager CLI.

We recommend that you make a plan for regular administration tasks [Extern].

#### Activities

You can use the Database Manager GUI or the Backup Wizard [Seite 42] for the following activities:

- **Managing the Backup Templates** [Seite 42]
- Executing backups (see Backup Procedures [Seite 46])
- **Checking backup** [Seite 70]
- **Displaying the Backup History** [Seite 63]
Backup Wizard

You can use the Backup Wizard to guide you through the entire process of backing up a database instance.

Procedure

In the Database Manager GUI, choose Instance → Backup → Backup Wizard.

Choose Next to start each of the required backup steps.

6. You can back up the data from a database instance either locally, or on a remote computer.
   Choose the desired database instance or enter the following information directly:
   - Database Server: Name of the computer on which the database instance is located
   - Database Name: Database name
   - User Name: Name of the Database Manager Operator (DBM Operator)
   - Password: Password of the Database Manager operator

7. If necessary, switch the database instance to the desired operational state.

8. Choose the desired backup type:
   - Complete Data Backup
   - Incremental Data Backup
   - Log Backup
   - Activate/deactivate automatic log backup
   Additionally, note the information about completed backups shown in the Backup Wizard.

9. Select a backup template.
   If no backup template is as yet available, you can create this (see Managing the Backup Templates).

10. Start the desired Backup Procedure.

11. Close the Backup Wizard.

Managing the Backup Templates

Use

Before you can back up data and log entries, you have to define backup templates. You can create and manage backup templates interactively with the Database Manager GUI or the Backup Wizard.

Features

- Backup Template for a Single Data Carrier
- Backup Template for a Group of Parallel Data Carriers
- Changing Backup Templates
- Deleting Backup Templates
- Checking backup

Backup Template for a Single Data Carrier

You can use the Database Manager GUI to back up to a single data carrier. To do this, you create a backup template for a single data carrier and use this when saving.
**Prerequisites**

You must have [connected the database instance to the DBM Server](Seite 16).

**Procedure**

Choose one of the following procedures:

- Select the required database instance in the list of database instances [Seite 8].
  
  Choose **Instance** → **Backup** → **Backup Medium**.
  
  Choose **Actions** → **New Medium**.

- [Backup Wizard](Seite 42)
  
  Choose **New Medium** in the Media for Backup window.

**General**

Choose **General** and enter the following information:

<table>
<thead>
<tr>
<th>Name</th>
<th>Name of the data carrier</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Backup Type</th>
<th>Select the required backup method:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><strong>Complete Data:</strong> complete data backup</td>
</tr>
<tr>
<td></td>
<td><strong>Incremental Data:</strong> incremental data backup</td>
</tr>
<tr>
<td></td>
<td><strong>Log Backup:</strong> log backup</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Device Type</th>
<th>Select the data carrier type:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><strong>File:</strong></td>
</tr>
<tr>
<td></td>
<td>If you choose the <strong>File</strong> type for log backups, the Database Manager writes the log backups to backup files.</td>
</tr>
<tr>
<td></td>
<td><strong>Tape:</strong></td>
</tr>
<tr>
<td></td>
<td>You cannot make log backups to tape.</td>
</tr>
<tr>
<td></td>
<td><strong>Pipe:</strong></td>
</tr>
<tr>
<td></td>
<td>Select <strong>Pipe</strong> if you intend to back up using a third-party backup tool.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Backup Tool</th>
<th>If you are using a third-party backup tool, choose the abbreviation for this backup tool here.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><strong>BACK:</strong> Backint for Oracle/Backint for MaxDB</td>
</tr>
<tr>
<td></td>
<td><strong>NSR:</strong> Networker</td>
</tr>
<tr>
<td></td>
<td><strong>TSM:</strong> TSM</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Device/File</th>
<th>Name of the data carrier with which this can be addressed using operating system functions.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Log backups with the type <strong>File</strong> are versioned by the system.</td>
</tr>
</tbody>
</table>

**Extended**

Choose **Extended** and enter the following information:

<table>
<thead>
<tr>
<th>Size</th>
<th>Size of data carrier</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Overwrite</th>
<th>Select <strong>Overwrite</strong> if you want to use the overwrite mode for the data carrier.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Block Size</th>
<th>Select <strong>Blocksize</strong> if you want to make backups in blocks of up to eight pages</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Autoloader</th>
<th>If you want to use a tape device with an automatic tape loader, select <strong>Autoloader</strong>.</th>
</tr>
</thead>
</table>

When you backup to tape, you can specify operating system commands.

**Result**

You can now use the backup templates you have defined to perform backups. Data carriers defined in a backup template can also be used as succeeding data carriers.

**Backup Template for a Group of Parallel Data Carriers**

To improve backup speed, you can use the Database manager GUI to back up data to multiple data carriers in parallel. To do this, you create a backup template for a group of parallel data carriers and use this when saving. When you restore, you can import the data from this type of backup in parallel.

**Prerequisites**

You must have connected the database instance to the DBM Server.

**Procedure**

Choose one of the following procedures:

- Select the required database instance in the list of database instances.
  
  Choose *Instance → Backup → Backup Medium*.

- Backup Wizard
  Choose *New Parallel Medium* in the *Media for Backup* window.

**General**

Choose *General* and enter the following information:

<table>
<thead>
<tr>
<th>Name</th>
<th>Name of backup template for a group of parallel data carriers</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Backup Type</strong></td>
<td>Select the required backup method:</td>
</tr>
<tr>
<td></td>
<td><em>Complete Data Backup</em>: Complete data backup</td>
</tr>
<tr>
<td></td>
<td><em>Incomplete Data Backup</em>: Incremental data backup</td>
</tr>
<tr>
<td><strong>Device Type</strong></td>
<td>Select the data carrier type:</td>
</tr>
<tr>
<td></td>
<td><em>File</em>: File</td>
</tr>
<tr>
<td></td>
<td><em>Tape</em>: Tape</td>
</tr>
<tr>
<td></td>
<td><em>Pipe</em>: Pipe</td>
</tr>
<tr>
<td></td>
<td>Select <em>Pipe</em> if you intend to back up using a third-party backup tool.</td>
</tr>
<tr>
<td><strong>Backup Tool</strong></td>
<td>If you are using a third-party backup tool, choose the abbreviation for the external backup tool here.</td>
</tr>
<tr>
<td></td>
<td><em>BACK</em>: Backint for Oracle/Backint for MaxDB</td>
</tr>
</tbody>
</table>
Name and Device/Path
Name and path of data carriers that you want to include in the group of parallel data carriers.
Change the defaults, or add new locations, depending on where you want to make the backups.

Extended
Choose Extended and enter the following information:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unit</td>
<td>Unit of measurement for specifying the sizes of data carriers</td>
</tr>
<tr>
<td>Overwrite</td>
<td>Select Overwrite if you want to use the overwrite mode for the data carriers</td>
</tr>
<tr>
<td>Block Size</td>
<td>Select Blocksize if you want to make backups in blocks of up to eight pages</td>
</tr>
<tr>
<td>Autoloader</td>
<td>If you want to use a tape device with an automatic tape loader, select Autoloader</td>
</tr>
<tr>
<td>Name/Size/OS Command</td>
<td>You can specify the size of each data carrier in the group. When you backup to tape, you can specify operating system commands.</td>
</tr>
</tbody>
</table>

Result
You can now use the backup template you have defined to perform backups. Data carriers grouped together in a backup template can also be used as succeeding data carriers.

Changing Backup Templates
You can make changes to a backup template. After it has been changed, the backup template is available for backup and recovery purposes in the Database Manager.

Procedure
- Database Manager GUI
  Select the required database instance in the list of database instances [Seite 8].
  Choose Instance → Backup → Backup Medium.
  Choose the backup template you want to use.
- Backup Wizard [Seite 42]
  Select the desired backup template in the Media for Backup window.

Changing the names of backup templates
1. Choose Action → Rename and then carry out your changes.
2. Choose Enter to save your changes.

Changing the properties of backup templates
3. Choose Action → Properties and make your changes.
4. You can find information on properties that can be changed in General and Extended in Backup Template for a Single Data Carrier [Seite 42] and Backup Template for a Group of Parallel Data Carriers [Seite 44].

To display the backup ID, choose Label.

See also:
Deleting Backup Templates

You can delete backup templates. Thereafter, the data carrier specified in the backup template is no longer available for backups and recovery in the Database Manager.

Procedure

- **Database Manager GUI**
  - Select the required database instance in the list of database instances. Choose Instance → Backup → Backup Medium.
  - Choose the backup template you want to use.

- **Backup Wizard**
  - Select the desired backup template in the Media for Backup window.

To delete the chosen backup medium, choose Action → Delete or Delete.

See also:
Managing the Backup Templates [Seite 42]

Backup Procedures

You can execute backups of data or log entries interactively with the Database Manager GUI or with the Backup Wizard. Depending on the technical requirements, the following backup procedures are possible:

- **Backing Up to a Single Data Carrier**
- **Backing Up to a Group of Parallel Data Carriers**

If the capacity of the selected data carrier(s) is sufficient for the total quantity of data or log entries that needs to be backed up, then the database administrator does not need to intervene during the backup process.

If the capacity of the selected data carrier/data carriers is not sufficient for the backup, succeeding data carriers must be used so that, when one data carrier is full, it is automatically or manually replaced by an empty data carrier:

- **Backups with Automatic Tape Loaders**
- **Backups with Manually Changed Data Carriers (Succeeding Data Carriers)**

When a data carrier has been completely filled but the backup has not yet been completed, the Backup Wizard requests additional data carriers. To allow it to do this, the data carrier size must be stated when defining the backup template, or the tape device must detect the end of the tape.

You also have the option of using third-party backup tools:

- **Backups Using Third-Party Backup Tools**

There is an automatic backup function for backing up the log entries:

- **Activating and Deactivating Automatic Log Backup**
Backing Up to a Single Data Carrier

You can use the Database Manager GUI to back up data or log entries to a single data carrier. If possible, we recommend that you back up data to a group of parallel data carriers, rather than backing up the data to a single data carrier with succeeding data carriers. You cannot make log backups in parallel.

Prerequisites

Only one backup device is available. You have created a backup template for a single data carrier.

If you want to perform a backup using an automatic tape loader (Backups with Automatic Tape Loaders), or with the help of third-party backup tools (Backups Using Third-Party Backup), then you must state this specifically when creating the backup template.

Under normal circumstances, you should back up database instances in the ONLINE operational state.

You can also back up database instances in the ADMIN operational state, but only in exceptional circumstances.

Procedure

Use the Backup Wizard.

5. If you have not yet created a backup template, you need to do this now as described in Backup Template for a Single Data Carrier. Select a backup template in the Media for Backup window.

6. Check the details. Make changes if required (Changing Backup Templates).

7. Start the backup, or activate automatic log backups. If the capacity of the specified data carriers is insufficient for the backup and you are not using an automatic tape loader, the Backup Wizard asks you to specify and insert a new data carrier as soon as the previous data carrier is full (see Backups to Manually Changed Data Carrier (Succeeding Data Carrier)).

Result

You can check the results of your log backups using the Backup History.

See also:

Backup Procedures

Backing Up to a Group of Parallel Data Carriers

You can use the Database Manager GUI to back up data to a group of parallel data carriers. This maximizes the data throughput. You can use up to 32 tape devices in parallel.
If possible, we recommend that you back up data to a group of parallel data carriers, rather than backing up to a single data carrier with succeeding data carriers. You cannot make log backups in parallel.

We recommend checking the database structures before each complete data backup.

**Prerequisites**

Multiple backup devices are available. You have created the required backup templates.

If you want to perform a backup using an automatic tape loader (Backups with Automatic Tape Loaders), or with the help of third-party backup tools (Backups Using Third-Party Backup Tools), then you must state this specifically when defining the backup template.

Under normal circumstances, you should back up database instances in the ONLINE operational state.

You can also back up database instances in the ADMIN operational state, but only in exceptional circumstances.

**Procedure**

Use the Backup Wizard.

1. If you have never made a backup copy for a group of parallel data carriers before, you need to do this as described in Backup Template for a Group of Parallel Data Carriers. Select a backup template in the Media for Backup window.

2. Check the details. Make changes if required (Changing Backup Templates).

3. Start the backup.

   If the capacity of the specified parallel data carriers is insufficient for the backup and you are not using an automatic tape loader, the Backup Wizard asks you to specify and insert a new data carrier as soon as the previous data carrier is full (see Backups to Manually Changed Data Carriers (Succeeding Data Carriers)).

**Result**

You can check the results of your data backups using the Backup History.

**See also:**

Backup Procedures

**Backups with Automatic Tape Loaders**

You can use the Database Manager GUI to back up data or log entries using automatic tape loaders. The Backup Wizard supports automatic tape loaders.

Alternatively, you can use a third-party backup tool (Backing Up Using Third-Party Backup Tools).

**Prerequisites**

Under normal circumstances, you should back up database instances in the ONLINE operational state.
You can also back up database instances in the ADMIN operational state, but only in exceptional circumstances.

Make sure you have enough tapes available.

⚠️ Before a backup, check that write-protection is disabled on all tapes otherwise the entire backup operation will be terminated.

**Procedure**

**Creating Backup Templates**

If you want to use an automatic tape loader, choose the following settings when you create the backup template (see [Backup Template for a Single Data Carrier](#), [Backup template for a Group of Parallel Data Carriers](#) or [Changing Backup Templates](#)):

- **General**
  Choose Tape as data carrier type (*Device Type*).

- **Extended**
  Select Autoloader.
  On the Microsoft Windows operating system, this defines automatic loading of tapes.
  If you are using any other operating system, use the appropriate command for loading tapes. Enter the operating system command in the *OS Command* field.

**Executing a Backup**

When you back up the data, proceed as described under [Backing Up to a Single Data Carrier](#) or [Backing Up to a Group of Parallel Data Carriers](#).

After you insert the tape cartridge in the autoloader, the first tape must be selected manually. When the end of this tape is reached, the autoloader will then take the next tape available.

**Result**

At the end of the backup, the tape device shows the number of tapes written. The tapes should be marked with the backup label which was displayed and confirmed at the start of the backup.

You can check the results of your log backups using the [Backup History](#).

**See also:**

[Backup Procedures](#)

---

**Backups to Manually Changed Data Carriers (Succeeding Data Carriers)**

You can use the Database Manager GUI to back up data or log entries using succeeding data carriers. If necessary, the [Backup Wizard](#) will ask you to change the data carrier (use a succeeding data carrier).

**Prerequisites**

Under normal circumstances, you should back up a database instance in the ONLINE operational state.

You can also back up database instances in the ADMIN operational state, but only in exceptional circumstances.
Procedure

You must have started a [Backup to a Single Data Carrier][47] or a [Backup to a Group of Parallel Data Carriers][47].

The capacity of the data carrier(s) you have inserted is not sufficiently large for the backup. The advancing bar showing the progress of the backup stops before reaching 100%.

The Backup Wizard prompts you to insert another data carrier.

Succeeding Data Carrier: Tape

1. Insert the next tape.
2. Ensure the tape that has just been written is stored in a safe place and that you insert the right tape.
3. Continue with the backup.

We recommend you specify the exact capacity of the tape when defining backup copies for tapes. As long as the tape device driver gives a reliable indication of when the end of the tape is reached, the Database Manager GUI reacts as described even when Size = 0.

If the end of the tape is not recognized correctly, the message [Writing Error][49] is displayed. Even when this happens you can continue as described in steps 1-3.

Succeeding Data Carrier: File

1. Under [New Location][45], enter the name and full path of the file to which the backup should be made.
2. Continue with the backup.

Result

Repeat the appropriate procedure for the data carrier type until the backup is complete.

While the backup procedure is in process, no other backup can be started.

You can check the results of your log backups using the [Backup History][63].

See also:

[Backup Procedures][46]

Backups Using Third-Party Backup Tools

You can use the Database Manager GUI to back up data or log entries using third-party backup tools. The [Backup Wizard][42] supports backups to tapes and succeeding tapes using third-party backup tools.

Prerequisites

[Connecting Third-Party Backup Tools][Extern]

Under normal circumstances, you should back up a database instance in the ONLINE operational state.

You can also back up database instances in the ADMIN operational state, but only in exceptional circumstances.
Procedure

Creating Backup Templates

If you want to use a third-party backup tool, ensure the following settings have been selected when you create the backup templates (see Backup Template for a Single Data Carrier [Page 42], Backup Template for a Group of Parallel Data Carriers [Page 44] or Changing Backup Templates [Page 45]):

**General**

- Choose a Pipe as the data carrier type (Device Type).
- Specify the operating system path of this pipe for the data carrier under Device/File.

Executing a Backup

When you back up the data, proceed as described under Backing Up to a Single Data Carrier [Page 47] or Backing Up to a Group of Parallel Data Carriers [Page 47]. Use the required backup templates.

Result

You can check the results of your log backups using the Backup History [Page 63].

See also:

Backup Procedures [Page 46]

Activating and Deactivating Automatic Log Backup

You can activate and deactivate automatic log backup with the Database Manager GUI.

Once you activate automatic log backup for your system, this setting remains active until you deactivate automatic log backup again. Automatic log backup also remains active when you restart the database instance.

Prerequisites

You need to perform a complete data backup before you activate automatic log backup.

The database instance is in the ONLINE operational state.

Procedure

Creating a Database Instance

You can activate/deactivate the automatic log backup when creating a database instance.

Proceed as described in Creating a Database Instance: Custom [Page 11].

Using the Backup Wizard

You can activate and deactivate automatic log backups with the Backup Wizard.

1. Start the Backup Wizard [Page 42].
2. If you have not yet created a backup template, you need to do this now as described in Backup Template for a Single Data Carrier [Page 42]. Select a backup template in the Media for Backup window.
3. Check the details. Make changes if required ([Changing Backup Templates [Seite 45]]).

4. If your database is in the ONLINE operational state, you can activate or deactivate automatic log backup ([Activate/deactivate automatic log backup]).

**Using the Database Manager GUI**

You can activate and deactivate automatic log backups with the Database Manager GUI.

Before you can make log backups, the required backup templates must be available.

1. Start the Database Manager GUI.
2. Choose *Instance*.
3. If your database is in the ONLINE operational state, you can activate or deactivate automatic log backups ([Set Auto Log ON/OFF]).

**Result**

The [List of Database Instances [Seite 8]] displays, among other things, whether automatic log backup is on or not ([Auto Log On/Off]).

You can check the results of your log backups using the [Backup History [Seite 63]].

**See also:**

[Backup Procedures [Seite 46]]

### Restoring

**Use**

To restore a database instance after an error or system failure, you can use the Database Manager GUI to import data and log backups. You can restore the database instance to its last state or to an earlier state.

You can also use the Database Manager GUI to restore indexes and mirrored log volumes.

- If the automatic log backup function has been activated before the recovery of the database instance started, this function is **not** automatically reactivated after the recovery.

**Activities**

You can usually use the Recovery Wizard to perform interactive recoveries of data. The *Recovery Wizard* proposes the optimal recovery strategy for your purposes. You can choose from the following procedures:

- Restoring the last backup in the backup history
- Restoring a backup from the backup history
- Restoring without a backup history
- Continuing an interrupted restore
- Restoring with automatic tape loaders
- Restoring with backup tools from other providers
If a restore is not possible using the above procedures (for example, because the database instance was deleted), you have to initialize the database and then restore it. The initialization process makes this a much lengthier procedure. Use it only if absolutely necessary.

- Restoring after initializing a database instance

You can also use the Database Manager GUI to restore indexes and mirrored volumes:

- Restoring the indexes after a database restore
- Restoring a mirrored log volume

**Recovery Wizard**

**Use**

You can use the *Recovery Wizard* to guide you through the entire process of restoring a database instance.

You can start the *Recovery Wizard* on a Windows-based server to restore data on either a local or remote server.

The *Recovery Wizard* always proposes the quickest procedure for recovering lost data. Complete data backups are read first and if necessary, incremental data backups and log backups are then read.

To make sure that the data is recovered as quickly as possible, data backups can be read from multiple data carriers at the same time. The number of media in a group of parallel data carriers does not have to be the same as the number of parallel data carriers used for the original backup. Even a backup made to a single data carrier with succeeding data carriers can be restored in parallel. You can reduce the restore times considerably by using up to 32 tape drives.

Log backups cannot be restored in parallel.

**Procedure**

In the Database Manager GUI, choose *Instance → Recovery → Recovery... .*

Choose *Next* to start each of the required recovery steps.

1. You can recover the data of a database in stance either locally, or on a remote computer.
   - Choose the desired database instance or enter the following information directly:
     - *Database Server*: Name of the computer on which the database instance is located
     - *Database Name*: Database name
     - *User Name*: Name of the Database Manager operator (DBM operator)
     - *Password*: Password of the Database Manager operator

2. You can switch the database instance to the operational state of your choice. When you recover data, you require the ADMIN operational state.

3. Choose a recovery type:
   - *Restore last backup*: Restoring from the last backup in the backup history
   - *Restore a specified backup from history*: Restoring a backup from the backup history
   - *Restore a medium*: Restoring without a backup history
   - *Continue restoring increment/log*: This setting is displayed if you need to continue an interrupted restore.

4. *Restore database until a specified time*: If you only want to restore the database up to a specific time, select this setting, and enter a time.
5. The recovery strategy is displayed. The system prompts you to insert the required data carrier.

6. Start the recovery.


**Result**

The database instance has been recovered to the state you specified.

If the recovery procedure provided by the Recovery Wizard does not produce the required results, you might have to use one of the procedures for restoring after initializing a database instance.

---

### Restoring the Last Backup in the Backup History

You can use the Recovery Wizard to restore interactively. You can perform a recovery that uses the last backup made.

**Prerequisites**

The log files `dbm.knl` and `dbm.mdf` exist and are not damaged. This means that the backup history is complete.

If you are restoring using third-party backup tools, the log file `dbm.ebf` must exist and must not be damaged.

The database instance is in the ADMIN operational state.

**Procedure**

Use the Recovery Wizard.

1. Choose **Restore last backup**.
   
   You can now choose a time up to which you want to restore data. In this case, select **Restore database until a specified time** and enter a time.
   
   The system default is the current time. If you do not change the time proposed by the system, the database instance is restored completely, including all changes.

2. The last complete data backup, the corresponding incremental backup, and the required log backups are displayed.
   
   You can remove the incremental data backup from the proposal. If you do this, the Recovery Wizard proposes the corresponding log backups, or another incremental data backup (if one exists).

3. The system prompts you to insert the specified data carrier.

4. Start the recovery.
   
   If you are performing a restore using third-party backup tools, the external backup IDs are displayed at this point.
   
   The complete data backup is restored.

5. If you are restoring an incremental data backup, the Recovery Wizard prompts you to confirm this.

6. If you need to restore log backups, the Recovery Wizard prompts you to confirm that you want to restore all the log backups displayed. After the log backups have been restored, the database instance is in the ONLINE operational state.
   
   If no log backups need to be restored, the recovery is complete. You can also specify an UNTIL time. Choose **Restart** to start the database instance.
When you restore a series of backups, the *Recovery Wizard* prompts you to insert the next backup data carrier each time, unless you are restoring from an automatic tape loader [Seite 57]. You can, if you wish, stop the restore process and resume it later on (see *Continue Interrupted Restore* [Seite 56]).

### Restoring a Backup from the Backup History

You can use the *Recovery Wizard* to restore interactively. You can perform a recovery with a complete data backup from the backup history.

#### Prerequisites

The log files *dbm.knl* and *dbm.mdf* of the Database Manager exist and are not damaged. This means that the backup history is complete.

If you are restoring with third-party backup tools, the log file *dbm.ebf* must also exist and not be damaged.

The database instance is in the ADMIN operational state.

#### Procedure

Use the Recovery Wizard.

1. Choose *Restore a specified backup from history*.
   You can now choose a time up to which you want to restore data. In this case, select *Restore database until a specified time* and enter a time.
   The system default is the current time. If you do not change the time proposed by the system, the database instance is restored completely, including all changes.

2. The backup history for all data backups is displayed.

3. Select the data backup you require.

4. The chosen data backup, the corresponding incremental data backup, and the required log backups are displayed.
   You can remove the incremental data backup from the proposal. If you do this, the *Recovery Wizard* proposes the corresponding log backups, or another incremental data backup (if one exists).

5. The system prompts you to insert the specified data carrier.

6. Start the recovery.
   If you are performing a restore using third-party backup tools, the external backup IDs are displayed at this point.
   The complete data backup is restored.

7. If you are restoring an incremental data backup, the *Recovery Wizard* prompts you to confirm this.

8. If you need to restore log backups, the *Recovery Wizard* prompts you to confirm that you want to restore all the log backups displayed. After the log backups have been restored, the database instance is in the ONLINE operational state.
   If no log backups need to be restored, the recovery is complete. You can also specify an UNTIL time. Choose *Restart* to start the database instance.
When you restore a series of backups, the *Recovery Wizard* prompts you to insert the next backup data carrier each time, unless you are restoring from an automatic tape loader [Seite 57].

You can, if you wish, stop the restore process and resume it later on (see *Continue Interrupted Restore [Seite 56]*).

---

**Restoring Without a Backup History**

You can use the *Recovery Wizard* to restore interactively. You can also perform a recovery if the backup history is not available.

**Prerequisites**

The database instance is in the ADMIN operational state.

The backup history contains errors or is no longer complete.

**Procedure**

Use the Recovery Wizard.

1. Choose *Restore a medium*.
   - You can now choose a time up to which you want to restore the information from a backup. In this case, select *Restore database until a specified time* and enter a time. The system default is the current time. If you do not change the time proposed by the system, the backups are restored in full together with all the changes they contain.

2. A list of all existing backup templates is displayed.

3. Select the backup template whose data is to be restored.
   - If you are performing a restore with a third-party backup tool, the system displays a list of backups. Select the required external backup IDs if necessary.

4. The system prompts you to insert the specified data carrier. If you are performing a restore using backup tools from other providers, the external backup IDs are displayed again at this point.

5. Start the recovery.
   - If you then want to recover more backups without a backup history, repeat this procedure.

6. Choose *Restart* to start the database instance.

   You can, if you wish, stop the restore process and resume it later on (see *Continue Interrupted Restore [Seite 56]*).

---

**Continuing an Interrupted Restore**

If a *Restore [Seite 52]* process is interrupted, you have the option of continuing it later with the *Recovery Wizard*.

**Prerequisites**

The database instance is in the ADMIN operational state.
One of several possible restore procedures has been started but canceled before it had been completed.

- Restoring from the Last Backup in the Backup History [Seite 54]
- Restoring a Backup from the Backup History [Seite 55]
- Restoring Without a Backup History [Seite 56]

**Procedure**

Use the Recovery Wizard [Seite 53].

1. Choose *Continue restoring increment/Log*.
   You have the option of restoring the database up to a specified time. In this case, select *Restore database until a specified time* and enter a time.
   The system default is the current time. If you do not change the time proposed by the system, the backups are restored in full together with all the changes they contain.

2. This displays a list of all relevant log backups made for data backups that have already been restored.

3. Continue with the restore process. You can follow the progress of the restore process and its completion on the screen [Seite 8] display.

4. Choose *Restart* to start the database instance.

When you restore a series of backups, the *Recovery Wizard* prompts you to insert the next backup data carrier each time, unless you are restoring from an automatic tape loader [Seite 57].

**Restoring with Automatic Tape Loaders**

You can interactively restore [Seite 52] using the Recovery Wizard [Seite 53]. You can optimize this process by using an automatic tape loader.

**Prerequisites**

For the retrieval operation to be successful, all the tapes which form part of the backup must be present in the automatic tape loader.

The database instance is in the ADMIN operational state.

**Procedure**

Use the same backup template as for backing up (Managing the Backup Templates [Seite 42]).

Follow the individual steps as described for the relevant recovery procedure:

- Restoring from the Last Backup in the Backup History [Seite 54]
- Restoring a Backup from the Backup History [Seite 55]
- Restoring Without a Backup History [Seite 56]
Restoring Using Third-Party Backup Tools

You can interactively restore [Seite 52] using the Recovery Wizard [Seite 53]. The Recovery Wizard supports the use of backup tools from other providers.

Prerequisites

Connecting Third-Party Backup Tools [Extern]

The database instance is in the ADMIN operational state.

Procedure

Start the recovery from the Recovery Wizard. The Recovery Wizard displays the external backup IDs for the user to check, and uses these during the restore operation. The user does not need to explicitly determine or specify the external backup IDs.

The number of data carriers in a group of parallel data carriers must be the same as the number of data carriers that was used for the creation of the backup.

Follow the procedure for the relevant restore process:

- Restoring from the Last Backup in the Backup History [Seite 54]
- Restoring a Backup from the Backup History [Seite 55]
- Restoring Without a Backup History [Seite 56]

Restoring After Initializing a Database Instance

When you restore [Seite 13] a database instance, you may need to initialize the database instance to delete the log entries in the log area. You can then restore the required backups to recover the database instance to a specified state.

There are two procedures for restoring after initializing a database instance. The procedure you choose depends on whether you want to change the database and volume settings before you restore the database instance.

You need to carry out a restore operation after initializing a database instance in the following situations:

- You want to recover a deleted database instance from a backup.
- You want to use backups from a point in time before you made a recovery with an UNTIL time. (For example, you want to repeat a recovery with an UNTIL time so that you can specify a different time.)

Any backups made before the interruption of the backup history can only be restored with the procedure described here.

This procedure involves the initialization of the database instance. This procedure is very time consuming. For this reason, you should only use it if absolutely necessary.
**Procedure**

There are two ways of initializing and then restoring a database instance.

- Restoring after initializing a database instance **without** the option of changing the database parameters and volume configuration.
- Restoring after initializing a database instance **with** the option of changing the database parameters and volume configuration.

**Restoring after initializing a database instance without the option of changing the database parameters and volume configuration**

**Prerequisites**

The database instance is in the ADMIN operational state.

**Procedure**

1. Choose *Instance → Recovery → Recovery with Initialization*.
2. If necessary, transfer the database instance to the ADMIN operational state.
3. The *Recovery Wizard* always proposes the quickest procedure for recovering lost data. You may need to choose a procedure that is adapted to your situation.
4. The wizard guides you through the entire process of recovering the database instance. The subsequent recovery steps are described under the relevant recovery procedure.

**Restoring after initializing a database instance with the option of changing the database parameters and volume configuration**

**Prerequisites**

The log files `dbm.knl` and `dbm.mdf` exist and are not damaged. This means that the backup history is complete. The database instance is in the OFFLINE operational state.

**Procedure**

5. Initialize the database instance. All data from the old version is then lost.
6. During the initialization process, choose *Create instance for recovery* (not *Create and start instance*), since this is the **only** option that lets you recover the data. Once it has been created, the database instance is in the ADMIN operational state. The Database Manager opens the *Recovery Wizard* [Seite 53] automatically.
7. The *Recovery Wizard* always proposes the quickest procedure for recovering lost data. You may need to choose a procedure that is adapted to your situation.
8. The wizard guides you through the entire process of recovering the database instance. The subsequent recovery steps are described under the relevant recovery procedure.

**Restoring the indexes after a database restore**

You can use the special database parameter `UseAutomaticBadIndexRecreation` to specify whether indexes marked as BAD are recreated automatically after a restore [Seite 52]. If this database parameter is set to NO and you have carried out a database recovery, you can then also recreate indexes marked as BAD explicitly.

**Prerequisites**

The database instance is in the ONLINE operational state.
**Procedure**

9. Choose **Instance → Recovery → Index**.

10. You can choose the tables for which the indexes marked BAD are to be displayed. To do so, enter appropriate search arguments for the owner, table name, and index name.

<table>
<thead>
<tr>
<th>Owner</th>
<th>Owner</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table Name</td>
<td>Name of the table</td>
</tr>
<tr>
<td>Index Name</td>
<td>Name of the index</td>
</tr>
</tbody>
</table>

11. Choose **Actions → Search**. A list of the indices that match your criteria is then displayed.

12. Select the indexes that you want to recreate.

13. Choose **Actions → Recreate** to perform the action.

We recommend that you restore the indexes during periods where the load on the system is low.

**See also:**
Activating, Deactivating, or Deleting Indexes [Seite 26]

---

**Restoring a Mirrored Log Volume**

If your log volumes are mirrored, it is possible that one of the volume mirrors may fail. If there are problems accessing the log area or the mirror log area, the affected log volume is flagged as BAD, and the database instance is transferred to the OFFLINE operational state.

You can use the Database Manager GUI to restore a damaged mirror log volume. In this process, the complete contents of the relevant log volume are copied from the other log area to the defective log volume. This ensures that the database instance does not have to be restored after a disk error that led to the loss of a log volume, as the content of the log volume was mirrored.

**Prerequisites**

The database instance is in the ADMIN operational state.

**Procedure**

1. Choose **Instance → Recovery → Volumes**.

   Select the **BAD** volumes that are to be recovered.

2. Choose **Actions → Reintegrate** to start copying the mirror volume.

---

**Freezing the Data Area (Snapshots)**

A snapshot freezes the current status of the data area. When you create a snapshot, you can continue to work with the data as normal and later revert to the state of the data area when the snapshot was made.

You can use the Database Manager GUI to create, use and delete snapshots.
A snapshot is not a data backup. To be able to restore your data after a system breakdown, you have to perform regular data and log backups.

**Prerequisites**

The database instance is in the ADMIN operational state.

**Process Flow**

1. You create a snapshot [Seite 61].
2. You continue to work with the data as normal.
3. You decide between the following two options:
   - Revert to the snapshot [Seite 61] (reject all the changes since the snapshot was made)
   - Delete the snapshot [Seite 62] (permanently accept all the changes since the snapshot was made)

**Creating a Snapshot**

You can use the Database Manager GUI to create a snapshot.

**Prerequisites**

The database instance is in the operational state ADMIN or ONLINE.

**Procedure**

We recommend that you activate overwrite mode for the log area in the log settings (see Changing the Log Settings [Seite 24]).

1. Choose Instance → Snapshot.
2. Choose Create Snapshot and confirm your input.

**Result**

The snapshot is created.

**See also:**

Freezing the Data Area (Snapshots) [Seite 60]

**Reverting to the Snapshot**

You can use the Database Manager GUI to revert the data area to its state at the time of the snapshot. By doing so, you discard all the changes that were made since the snapshot was created.

When you revert to the snapshot, all the log entries written up to this point are deleted. In other words, the backup history is interrupted. You have to carry out a complete data backup before you can perform a log backup.
**Prerequisites**
The database instance is in the ADMIN operational state.

**Procedure**
1. Choose *Instance* → *Snapshot*.
2. Choose *Revert to Snapshot* and confirm your entry.

*See also:*
[Freezing the Data Area (Snapshots) [Seite 60]]

---

### Deleting the Snapshot

You can use the Database Manager GUI to delete the snapshot. If you do so, all the changes that have occurred in the data area since the snapshot are adopted.

**Prerequisites**
The database instance is in the ADMIN operational state.

**Procedure**
1. Choose *Instance* → *Snapshot*.
2. Choose *Delete Snapshot* and confirm your input.

*See also:*
[Freezing the Data Area (Snapshots) [Seite 60]]

---

### Displaying Information

You can get a general overview of the information and statistics on important database functions available in the Database Manager GUI.

In the Database Manager console you can display all DBM commands from the Database Manager GUI that are executed for actions involving the administration of a database instance.

**Procedure**
1. Select the required database instance in the list. [list of database instances [Seite 8]]
2. Connect to the DBM server [Seite 16] for this database instance if necessary.
3. Select *Instance* → *Information*.
4. Choose the area for which you wish to obtain detailed information.

To start the Database Manager console, chose *Instance* → *Database Manager Console*.

**Result**
Information is given on the following topics:

<table>
<thead>
<tr>
<th>Activity</th>
<th>Displaying Database Activities [Seite 65]</th>
</tr>
</thead>
<tbody>
<tr>
<td>Caches</td>
<td>Displaying Cache Information [Seite 64]</td>
</tr>
<tr>
<td>Data Area</td>
<td>Displaying Data Area Information [Seite 64]</td>
</tr>
</tbody>
</table>
If you use the Database Manager Console, in the console’s display you can track which DBM commands are used for which administrative tasks. You can save the DBM commands as required in a file you have defined, or you can use them directly for executing administrative tasks with Database Manager CLI.

See also:
Diagnosis Options [Page 69]

Displaying the Backup History

You can display a chronological list in the Database Manager GUI of all backup and restore operations that have been executed (Backup history).

Procedure

1. Select the required database instance in the list of database instances [Page 8]. Connect to the DBM server [Page 16] for this database instance if necessary.

2. Choose Instance → Information → Backup History or choose Instance → Backup → Backup History

Result

Each action displays the following information:

<table>
<thead>
<tr>
<th>Label</th>
<th>Backup ID</th>
</tr>
</thead>
<tbody>
<tr>
<td>Action</td>
<td>The action (backup or recover) and the operational state in which it took place.</td>
</tr>
<tr>
<td>Start</td>
<td>Time when the action began</td>
</tr>
<tr>
<td>Result</td>
<td>Result</td>
</tr>
<tr>
<td>Medium</td>
<td>Name of the backup template.</td>
</tr>
<tr>
<td>Size (Pages)</td>
<td>Size (pages)</td>
</tr>
<tr>
<td>Volumes</td>
<td>Volumes</td>
</tr>
<tr>
<td>Next Log Page</td>
<td>I/O sequence number</td>
</tr>
<tr>
<td>From Page</td>
<td>From I/O sequence number</td>
</tr>
<tr>
<td>To Page</td>
<td>To I/O sequence number</td>
</tr>
</tbody>
</table>

To receive more information about a backup, choose the required backup ID in the backup history. When using third-party backup tools, the external backup ID will be displayed plus the status of the backup with third-party backup tools. Choose Action → Close to exit this.

Choose Action → Refresh with External Backup Info to update the backup history.

See also:
Backup [Page 41]
Displaying Cache Information

You can display the hit rate of the caches in the Database Manager GUI. These hit rates show you whether the caches have been configured with enough space. The hit rates for the data cache and the converter are particularly important.

Prerequisites

The database instance is in the ONLINE operational state.

Procedure

1. Select the required database instance in the list of database instances [Seite 8]. Connect to the DBM server [Seite 16] for this database instance if necessary.

2. Choose Instance → Information → Caches.

3. The following information is displayed for the different caches:

<table>
<thead>
<tr>
<th>Accesses</th>
<th>Total number of accesses</th>
</tr>
</thead>
<tbody>
<tr>
<td>Successful</td>
<td>Number of successful accesses</td>
</tr>
<tr>
<td>Unsuccessful</td>
<td>Number of unsuccessful accesses</td>
</tr>
<tr>
<td>Hit Rate (%)</td>
<td>Hit rate (number of hits as a percentage of the total number of accesses)</td>
</tr>
</tbody>
</table>

The current values of certain database parameters that can affect the caches are also displayed.

Result

The hit rate of the data cache should be at least 99% and the converter hit rate should be at least 98%.

Lower hit rates can occur for a short time, for example when tables are read for the first time, or when the table does not fit into 10% of the data cache in the case of repeated table scans. If the values are permanently lower than the recommended percentage, this is a sign of poor performance. In this case, the CacheMemorySize general database parameter must be adjusted accordingly.

Displaying Data Area Information

You can display information on the size and current usage of the data area in the Database Manager GUI.

Procedure

1. Select the required database instance in the list of database instances [Seite 8]. Connect to the DBM server [Seite 16] for this database instance if necessary.

2. Choose Instance → Information → Data Area.
Result
The display is divided into the following areas:

- **Volumes**: Information about the data volumes
- **Settings**: Value of the `MaxDataVolumes` database parameter
- **Usage**: Usage of the data area
- **I/O**: Reads and writes for each data volume

Volumes
Among other things, you see the following information for each data volume: name, size, type, and path in the run directory.

Settings
The maximum number of data volumes is controlled by the general database parameter `MaxDataVolumes`. The current value of this database parameter is displayed.

Usage
If the database instance is in the ONLINE operational state, you can display the usage of the data area.

<table>
<thead>
<tr>
<th>Description</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total Size</td>
<td>Total size of the data area</td>
</tr>
<tr>
<td>Used Area</td>
<td>Used data area</td>
</tr>
<tr>
<td>Permanent Used Area</td>
<td>Data area used by permanent data</td>
</tr>
<tr>
<td>Temporary Used Area</td>
<td>Data area used by temporary data</td>
</tr>
<tr>
<td>Free Area</td>
<td>Unoccupied data area</td>
</tr>
</tbody>
</table>

You also see the fill level of each data volume.

I/O
If the database instance is in the ONLINE operational state, you can display the read and write activities for each data volume.

See also:
- Creating, Displaying and Deleting Volumes [Seite 20]
- Changing Volume Properties [Seite 21]
- Changing Database Parameters for Volumes [Seite 22]
- Switching on/off Automatic Extension of the Data Area [Seite 23]

Displaying Database Activities
You can display the database activities in the Database Manager GUI.

Prerequisites
The database instance is in the ONLINE operational state.

Procedure
1. Select the required database instance in the list of database instances [Seite 8].
   Connect to the DBM server [Seite 16] for this database instance if necessary.
2. Choose **Instance → Information → Activity**.
3. You see a display of the database activities, split into the following sections:
   - **Commands**: Information about the SQL statements
   - **I/O Activity**: Information about the read and write activities
   - **Lock Activity**: Information about lock activities
   - **Log Activity**: Information about log activities
   - **Scan and Sort Activity**: Information about table scans

### Commands

The **Commands** section includes the following information about the SQL statements:

<table>
<thead>
<tr>
<th>Statement Type</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>SQL Commands</td>
<td>Number of SQL statements sent to the database system to be executed. A direct indication of database activity.</td>
</tr>
<tr>
<td>Prepares</td>
<td>Number of dynamic SQL statements.</td>
</tr>
<tr>
<td>Executes</td>
<td>Number of executed dynamic SQL statements.</td>
</tr>
<tr>
<td>Rollbacks</td>
<td>Unsuccessful database operations, usually caused by crashed applications.</td>
</tr>
<tr>
<td>Commits</td>
<td>Successful database operations. The ratio between ROLLBACK actions and COMMIT actions can indicate logical inconsistencies in one or more SQL statements.</td>
</tr>
<tr>
<td>Updates, Selects and Fetches, Creates, Alters, Drops, DB procedure calls, Deletes, Inserts</td>
<td>Number of individual SQL statements, possibly with row information</td>
</tr>
</tbody>
</table>

### I/O Activity

The **I/O Activity** section gives you information about I/O activities triggered by the database system. This includes information about the logical and physical read and write transactions.

In a physical read or write activity, the system accesses a volume directly. A logical read or write activity, on the other hand, uses data stored in the data cache or another cache.

### Lock Activity

The **Lock Activity** section gives you information about the maximum number of available database locks (**Available Entries**), as well as the number of locks that have been set. If the number of set locks is approaching the number of available locks, it is a good idea to raise the value of the general database parameter `MaxSQLLocks`.

**Escalations** shows you the total number of rows that have been locked in a single database session. As soon as the number of locked rows exceeds a specific percentage, the database system locks the entire table. The threshold for **Escalations** is based on the `MaxSQLLocks` value for this database instance.

If a locked object is requested again, a lock conflict occurs. If a large number of collisions occurs in your system, this means that a specific lock is being held too long, or multiple users are trying to access the same part of the database too often.

The values of **Lock Owner** and **Lock Requestor** relate to the locks that exist when the transaction is executed.
**Scan and Sort Activity**

The **Scan and Sort Activity** section shows you information about the table scans, among other things.

Keep the number of table scans to a minimum, since a high number of sequential scans can have a negative effect on database performance.

---

**Displaying Database Parameters**

In the Database Manager GUI, you can display all the database parameters, as well as a chronological list of all changes made to these parameters.

**Procedure**

1. Select the required database instance in the list of database instances. Connect to the DBM server for this database instance if necessary.
2. Choose **Instance → Information → Parameters**.
3. The display of the database parameters is divided into the following sections:
   - **General**: Displays the general database parameters
   - **Extended**: Displays the special database parameters
   - **Support**: Displays the support parameters
   - **History**: You can use the parameter history to find out when a parameter setting was changed, and check the old and current values of the parameter. In addition, user-defined comments for the individual parameters are displayed in the history.

**See also:**

Displaying and Changing Database Parameters

---

**Displaying Database Sessions**

**Prerequisites**

The database instance is in the ONLINE operational state.

**Procedure**

1. Select the required database instance in the list of database instances. Connect to the DBM server for this database instance if necessary.
2. Choose **Instance → Information → Sessions**.
3. The following information is displayed:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of the database user logged on</td>
</tr>
<tr>
<td>Terminal ID</td>
<td>Terminal identification dependent on operating system.</td>
</tr>
<tr>
<td>Task ID</td>
<td>Number of user task</td>
</tr>
<tr>
<td>Session ID</td>
<td>Number of the database session</td>
</tr>
<tr>
<td>Node</td>
<td>Name of the database computer</td>
</tr>
</tbody>
</table>
### Displaying Log Area Information

You can display information on the size and current usage of the log area in the Database Manager GUI.

#### Procedure

1. Select the required database instance in the list of database instances. Connect to the DBM server if necessary.
2. Choose **Instance → Information → Log Area**.

#### Result

The display is divided into the following areas:

- **Volumes**: Information about the log volumes
- **Settings**: Information about the log settings, values of the database parameters `MaxLogVolumes` and `AutoLogBackupSize`
- **Usage**: Usage of the log area
- **I/O**: Reads and writes for each log volume
- **Activity**: Summary of the log activities

#### Volumes

Among other things, you see the following information for each log volume: name, size, type, and path in the run directory.

#### Settings

You can control redo log management by making various log settings. The following settings are displayed:

- **Log Mode**
  - SINGLE: The log volumes are not mirrored.
  - MIRRORED: The log volumes are mirrored.

- **Overwrite Mode**
  - NORMAL: The log area cannot be overwritten until the log entries have been backed up.
  - OVERWRITE: The log area is overwritten when it is full.

- **Redo Log Management**
  - ACTIVATED: Redo log management is activated.
  - DEACTIVATED: Redo log management is deactivated.

#### See also:

- [Changing Log Settings](#)
of segment that is chosen when log backups are made. The current values of these database parameters are displayed.

**Usage**

If the database instance is in the ONLINE operational state, you can display the usage of the log area.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total Size</td>
<td>Total size of the log area</td>
</tr>
<tr>
<td>Free Log Area</td>
<td>Free log area</td>
</tr>
<tr>
<td>Used Log Area</td>
<td>Used log area</td>
</tr>
<tr>
<td>Unsaved Log Area</td>
<td>Size of the log area that has not yet been backed up</td>
</tr>
<tr>
<td>Log since last data backup</td>
<td>Log entries written since the last data backup</td>
</tr>
</tbody>
</table>

**I/O**

If the database instance is in the ONLINE operational state, you can display the read and write activities for each log volume.

<table>
<thead>
<tr>
<th>Activity</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Log Pages Written</td>
<td>Written log pages</td>
</tr>
<tr>
<td>Wait for Log Writer</td>
<td>Indicates how often it was necessary to wait for a log entry to be written</td>
</tr>
<tr>
<td>Group Commits</td>
<td>Indicates how often more than one transaction had to wait for the I/O operation for a log page</td>
</tr>
<tr>
<td>Log I/O Queue Overflow</td>
<td>Indicates how often a transaction had to wait to write a log entry because the log queue was full</td>
</tr>
</tbody>
</table>

**Displaying System Tables**

You can use the Database Manager GUI to display the system tables that are assigned to the SYSINFO schema. These system tables contain information about the database states.

**Prerequisites**

The database instance is in the ONLINE operational state.

**Procedure**

1. Select the required database instance in the list of database instances. Set up the connection to the DBM server for this database instance.
2. Choose **Instance → Information → System Tables**. A list of system tables is displayed.
3. Click the desired table.

**Result**

The status information that is stored in this table is displayed.
Options for Diagnosing Problems

In the event of errors or performance problems, the Database Manager GUI offers you a number of options for diagnosing the problem. You can also use other database tools to carry out your performance diagnosis.

Procedure

1. Select the required database instance in the list of database instances [Seite 8]. Connect to the DBM server [Seite 16] for this database instance if necessary.
2. Choose one of the following diagnosis options or database tools:

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Significance</th>
</tr>
</thead>
<tbody>
<tr>
<td>Instance → Check → Database Structure</td>
<td>Checking Database Structures [Seite 72]</td>
</tr>
<tr>
<td>Instance → Check → Backup</td>
<td>Checking Backup [Seite 70]</td>
</tr>
<tr>
<td>Instance → Check → Database Server</td>
<td>Checking the Database Computer [Seite 71]</td>
</tr>
<tr>
<td>Instance → Check → Diagnosis Files</td>
<td>Reading Log Files [Seite 72]</td>
</tr>
<tr>
<td>Instance → Check → Database Trace</td>
<td>Using the Database Trace [Seite 73]</td>
</tr>
<tr>
<td>Instance → Check → Database Analyzer</td>
<td>Displaying and Deleting Database Analyzer Information [Seite 71]</td>
</tr>
<tr>
<td>Tools → SQL Studio</td>
<td>Using SQL Studio [Seite 76]</td>
</tr>
<tr>
<td>Instance → Command Line</td>
<td>Using the Database Manager CLI [Seite 77]</td>
</tr>
<tr>
<td>Instance → OMS Caches</td>
<td>For liveCache instances only; Displaying OMS Caches [Seite 74]</td>
</tr>
<tr>
<td>Instance → OMS Container</td>
<td>For liveCache instances only; Displaying OMS Class Containers [Seite 74]</td>
</tr>
<tr>
<td>Instance → OMS Monitor</td>
<td>For liveCache instances only; Activating the OMS Monitor [Seite 75]</td>
</tr>
</tbody>
</table>

See also:
Displaying Information [Seite 62]

Checking Backups

You can use the Database Manager to check whether a backup can be read.

Procedure

1. Select the required database instance in the list of database instances [Seite 8]. Connect to the DBM server [Seite 16] for this database instance if necessary.
2. Choose Instance → Check → Backup.
3. Choose Next to start each of the required steps.
4. Choose the type of check you want to carry out.
○ Check last backup: Check the last backup created
○ Check a specified backup from history: Check a specific backup from the backup history
○ Check a medium: Check a backup from a particular backup medium

5. Select the backup template that you wish to check.
6. Choose Start.

Result
The backup check is started.
If the check finds an error, a message is displayed accordingly.

See also:
Backup [Seite 41]

Displaying and Deleting Database Analyzer Information
You can use the Database Manager GUI to display status information about the Database Analyzer and to delete Database Analyzer logs.

Prerequisites
The database instance is in the ONLINE operational state.

Procedure
1. Select the required database instance in the list of database instances [Seite 16]. Connect to the DBM server [Seite 16] for this database instance if necessary.
2. Choose Instance → Check → Database Analyzer.

Result
You receive status information about the Database Analyzer. For more information about the Database Analyzer, see the Database Analyzer documentation.
If you want to delete Database Analyzer logs, choose Actions → Delete Protocols. Specify the date starting from which the log files of the Database Analyzer are to be deleted.

Checking Database Servers
The Database Manager GUI provides you with an overview of the operating system resources that the database instance is using, how the database sessions have been distributed among the threads and the status of the active database sessions.
There are additional functions available, but these should be reserved for support employees and developers.

Prerequisites
The database instance is the ONLINE or the ADMIN operational state.
Procedure

1. Select the required database instance in the list of database instances [Seite 8]. Connect to the DBM server [Seite 16] for this database instance if necessary.

2. Choose Instance → Check → Database Server.

3. Select the type of information you want.

4. To display the details, choose Actions → View.

Reading Log Files

The database system has a number of log files. You can access the available log files from the Database Manager GUI.

Procedure

1. Select the required database instance in the list of database instances [Seite 8]. Connect to the DBM server [Seite 16] for this database instance if necessary.

2. Choose Instance → Check → Diagnosis Files.

3. Select the file you want.

Checking Database Structures

You can use the Database Manager GUI to check whether the database structures of a database instance are consistent. The length and ascending order of the keys are checked, among other things.

We recommend that you check the database structures once a week.

This check is extremely CPU intensive and time consuming because many I/O operations have to be carried out. Plan checks in the production system only for times when the load on the database system is reduced or carry out the check on a database copy.

Prerequisites

The database instance is in the ONLINE or ADMIN operational state.

Procedure

1. Select the required database instance in the list of database instances [Seite 8]. Connect to the DBM server [Seite 16] for this database instance if necessary.

2. Choose Instance → Check → Database Structure.

3. Choose the required function and specify the relevant options in the following step.

Functions and Options for Checking the Database Structure

<table>
<thead>
<tr>
<th>Function</th>
<th>Operational state</th>
<th>Command</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Checking the entire dataset</td>
<td>ONLINE</td>
<td>Check database structure in</td>
<td>EXCEPT INDEX: Indexes are not checked. This option</td>
</tr>
</tbody>
</table>
### Operational State

| Checking the entire dataset and cleaning the converter | ADMIN | Check database structure and clear converter in operational state ADMIN |
| Checking a selected table | ONLINE | Check database structure for a selected table in operational state ONLINE |

**WITH LONG CHECK:** If the base table to be checked contains LOB columns, the system checks whether all the LOB values defined actually exist. To ensure the consistency of the transaction, an SQL share lock is requested for the duration of the check.

**CATALOG:** The database catalog for this table is checked. This option cannot be combined with the EXTENDED and WITH LONG CHECK options.

4. To start the database structure check, choose *Start*.

5. After the check has been completed, choose *Close*.

### Result

Errors encountered during the database structure check are written to the Database Errors log file. You can open this file for further evaluation purposes.

---

### Using the Database Trace

The Database Manager GUI gives you the option of enabling the database trace if errors occur.

The database trace only adversely affects performance in liveCache database instances; in other database instances, you can use the database trace even in normal operation.

#### Procedure

1. Select the required database instance in the list of database instances [Seite 8].
   
   Connect to the DBM server [Seite 16] for this database instance if necessary.

2. Choose *Instance → Check → Database Trace*.

3. You can execute the log functions below either individually or group, which you can define yourself.

#### Logging Database Statements in General

- On the *Options* tab page, select the required database trace options in the list. If the options support the selection of a trace level, the system default value is displayed in the *Level* column.
Choose Actions → Selected Items ON to activate the database trace for the chosen database trace options.

If you want to change the trace level for the selected database trace options, choose Actions → Selected Items ON with Level... You can now select a different trace level. The higher the trace level, the greater amount of detail is provided in the information collected by the database trace.

Choose Actions → Selected Items OFF to disable the database trace.

Logging Database Statements in a Specific Database Session

The database trace is written for all database sessions by default. The default setting can be changed if necessary:

4. Choose the Advanced tab page and select Trace session.
5. Decide whether the database trace is to be written for the current session or for a specific database session. In this case, enter the ID of the database session (for information about finding the ID, see Displaying Database Sessions [Seite 67]).
6. Choose Actions → Set Advanced Options.

Logging the Occurrence of Specific Errors

7. On the Advanced tab page, select Stop on error. Enter the code of the error whose occurrence is to stop the creation of the database trace.
8. Then choose Actions → Flush to write the information still contained in the buffer to the trace and therefore update the database trace before the log file is created.

Creating and Display the Database Trace Log

10. Then choose Actions → Flush to write the information still contained in the buffer to the trace and therefore update the database trace before the log file is created.
11. Choose Actions → Make Protocol. The database trace is then converted to a legible format.

To open the log, choose Instance → Check → Diagnosis Files. Select the Kernel Trace Protocol file and choose Actions → View.

Displaying OMS Caches

This Database Manager GUI function supports performance analysis of a SAP liveCache database instance.

Prerequisites

The current database instance is a liveCache instance.

The database instance is now in the ONLINE operational state.

Procedure

1. Select the required database instance in the list of database instances [Seite 8]. Connect to the DBM server [Seite 16] for this database instance if necessary.
2. Choose Instance → Information → OMS Caches.
**Result**

The OMS caches are displayed.

---

**Displaying OMS Class Containers**

This Database Manager GUI function supports performance analysis of a SAP liveCache database instance.

**Prerequisites**

The current database instance is a liveCache instance.

The database instance is now in the ONLINE operational state.

**Procedure**

1. Select the required database instance in the [list of database instances](#).

2. Choose **Instance → Information → OMS Class Containers**.

**Result**

Information about the class containers is displayed.

---

**Activating the OMS Monitor**

This Database Manager GUI function supports performance analysis of a SAP liveCache database instance.

**Prerequisites**

The current database instance is a liveCache instance.

The database instance is now in the ONLINE operational state.

**Procedure**

1. Select the required database instance in the [list of database instances](#).

2. Choose **Instance → Information → OMS Monitor**.

**Result**

The OMS monitor is activated.

---

**Updating the Database Software**

After you have updated the database software, you can use the Database Manager GUI to make sure that the database instance recognizes the new software version.

**Procedure**

3. Update the database software.
4. **Start the database instance [Seite 17].**
   The first time the Database Manager GUI is started after updating the database software, it automatically adjusts the database parameters of the database instance to the database parameters of the new database software version and updates the system tables.

### Result

The Database Manager creates a copy of the parameter file each time a database parameter is changed.

**UNIX:** `<independent_data_path>/config/<database_name>.<running_number>`

**Windows:** `<independent_data_path>\config\<database_name>.<running_number>`

<running_number>: Version of the copy, starting with 01

- Should errors occur while loading the parameters, the operation can be undone by restoring the original parameter file.
- To do this, use the Database Manager CLI program to copy the file `<database_name>.<running_number>` (copy of parameter file) back to `<database_name>` (active parameter file).

### Updating the System Tables

You can use the Database Manager GUI to update the system tables.

**Prerequisites**

The database instance is in the ONLINE operational state.

**Procedure**

1. Select the required database instance in the list of database instances [Seite 16].
2. Choose **Instance → Configuration → Upgrade System Tables**.
3. Start the update for the system tables. The Database Manager determines the necessary database user. If this is not possible, you are prompted to provide the user details yourself.

### Result

The system tables are loaded and updated. At the end of the operation, the log `dbm.ins (Installation Protocol)` is displayed.

- If an error occurs, the **ERROR** status appears. In this case, analyze the **Installation Protocol** as described in **Reading Log Files** [Seite 72].

### Using the SQL Studio

You can call the query tool SQL Studio from the Database Manager GUI. This program enables you to access the data of a database instance.
Prerequisites
You have the authorization of a database user of this database instance.

Procedure
Choose Tools → SQL Studio. 

For information about this tool, see the documentation for SQL Studio.

Using the Database Manager CLI
You can call the command line version of the Database Manager, the Database Manager CLI, from the Database Manager GUI.

Procedure
4. Select the required database instance in the list of database instances [Seite 8].
   Connect to the DBM server [Seite 16] for this database instance if necessary.
5. Choose Instance → Command Line.
6. Enter the desired DBM commands.
7. Choose Actions → Execute.

Result
The required DBM command is executed.

In the Database Manager console you can display all DBM commands from the Database Manager GUI that are executed for actions involving the administration of a database instance.

See also:
Displaying Information [Seite 62]